Importing Basic Mass plugins Issue

Hello,
This page commited/updated yesterday:
Viewpoint Development · eclipse/capella Wiki · GitHub
mentions in option#1 the possibility of importing the plugins via file > import…


I encontered a little problem though, two type of errors:

Did that happen to anyone?
@ArnaudDieumegard if you find a moment. Thanks a lot.
Ps. by the way, all the pluginName.source… got me a “access refused” and were not added, don’t know if that supposed to happen or not.

Hi,

I think all your errors are linked to the fact that you do not have the sources. Which should be the case.
How did you install the basic mass viewpoint (dropins, updatesite) for which version ? If you go to your install folder, do you have the .source plugins ?

Two things bothers me on you screen captures:
image
Sources from git.polarsys.org have moved to github.com

image
This version 1.2.0 with a qualifier 2020… does not exists in the official releases Project download area | The Eclipse Foundation

Maybe you could try to install the viewpoint from this source, it may solve you problem.

Regards,
Arnaud

1 Like

Hello,
I actually downloaded from the website, under the “Sample Add-ons” section:

I did the following:

  • unzip all plugins and features info unzipped files. and put them all inside one directory.
  • Went to Menu > import > plugins and frag. → Chose the directory mentioned earlier, press OK and then OK.

When the files load, i obtain an error message stating that the files.sources are refused (access refused).

I wonder if that has any link to the fact I am not using Capella Studio as an “admin”.

My directory in situated in Desktop, if I don’t do that, I would obtain an error message such as this one:
java - eclipse cannot import project from open file system? - Stack Overflow

So maybe moving to desktop only resolved partially the issue. I should retry all of this with a computer with admin rights.
I will also try with your link later (not today).

Hello Arnaud
First of all, the problem was an “admin” one, when using CS in the “DESKTOP” all admin requirements go away and the message error associated to source files did not appear anymore.

  1. I think, I have been IMPORTING plugins the wrong way, what i did was
  • Opening CS

  • Go to Project Explorer and right click

  • Select “Import…”

  • Plug-ins and Fragments → Select the directory “plugins” of the addon I am interested

  • In the Import As, section I chose once “Binary Projects” and in another try “Projects with source folders”
    image

  • Add all plugins

  • Then try to open the .spec with the right opener (right click → open with → specifier)

  • Try to do that to each vptext file

  • Then GENERATE

  • Launch the runpoint and then i got a message error about “org.eclipse.emf.cdo

I DON’T KNOW WHY.
I went to the manifest file and the dependencies, and indeed there is a problem with one “bundle” and I have no idea why/how etc

The problem arises when launching the runtime like this:
image


I tried to use the latest version version of “Mass” using your link, btw.
Any idea what is missing?

In any case, I tried to run the runtime anyway, and I noticed that the mass appears correctly on the palette (when the PAB is opened) HOWEVER, when you drag and drop the mass on the physiscal component, NOTHING HAPPENS, it does not create a new element linked to the physical component. That is supposed to work.


I have an interesting question @ArnaudDieumegard , could the problem caused by the method I am “importing” the plugings? I noticed that you described a slightly different method involving the VIEWPOINT plug-in here Viewpoint Development · eclipse/capella Wiki · GitHub

You mention the method:“Import As”/“Source Project” command.
Could this be the source of the problem? (Me importing the plugins without using the plugin viewpoint that you mentioned?)

I tried your method but the mass plugins are NOT available on the list, we cannot select them.


What do you think is the problem here? (Again ultimately when running it, the fist problem is that the mass icons would not be “created” NOR “attached to a physical link”, let’s say).
Thanks

I Hope this is clear, tell me if it isn’t please.

EDIT:
I tried with an outdated verstion (the one from the official Capella Website), something interesting happened :

Importing the plugins → Then running the runtime → Everything’s fine. The mass icons are created next to the physical components.
Whenever i RE-GENERATE → mass icons are not created. the palette is there in the PAB, but drag and droping the mass icons unto a physical component does not do anything.

Hi,

Regarding the org.eclipse.emf.cdo dependency, be aware that this plugin is only required when you are in a TeamForCapella context, so when working on a simple Capella environment, these “.cdo” plugins shall not be included in the build (org.polarsys.capella.vp.mass.model.cdo). In order to do so, simply close the project or untick it form the list of plugins in the “Plug-ins” tab in the “Run configuration”. INcluding this plugin anyways will make emf use the wrong implementation for model elements and thus leads to the error.

This cdo code being present in the most recent version comes from the fact that we recently re-generated the viewpoint to include the cdo content that was long missing.

Regards,
Arnaud

Hello Arnaud,
Thanks. Strangely enough i got rid of the problem of the .cdo when i used the right version of the addon. Althoght I must add: we do not use TeamForCapella.
However I am still facing the same problem which is :

Whenever i import the plugins, then start a new “regeneration” of the viewpoint, then go test it inside a runtime → The addon will not work anymore. It is there, but drop and draging the basicmass from the palette to the PC will not “create” an icon inside the physical component. That problem does not occure as long as I did not “regenerate” the viewpoint again.
I think problem comes from the way I am importing the plugins. You mention in your tutorial the use of the view “plug-in” and you have a screen shot where we see the plugins in the list displayed by the view. However, in my case I cannot see the plugins on that list, so I find myself “importing” them through a regular right click → import.

I am not able to reproduce the import method you described in your tutorial. And I think that is why I am not being able to use the plugin Basic Mass correctly. (It does not work after being regenerated)

So that’s where lies the actual problem, and I don’t know how to solve it. That happens with all addons i try to “import”’ following my method => without the view “plug-in”. Any idea what could be the problem?

Hello,
In order to get the mass plugins in the “Plug-ins” view, the plugins needs to be installed on the platform (meaning your Capella Studio) so by extracting the dropin version of the addon to the dropins folder or by installing the addon through the update site.

image

I just tried it with Capella Studio 5.2.0 and the Basic Mass viewpoint 5.1.0. It does works correctly and if I regenerate the viewpoint from the vpdsl files and restart in runtime then it still works.

Regards,
Arnaud

1 Like