Rich text in description property-> Https & Web Brower

Hello
Rich text editor for description of model element seems to not available in capella 1.2 as shown during webinar.
Here is the screenshot. Am I missing anything?
Best
Arun

Hi,
I mentioned during the webinar this is still an add-on with version 1.2.0 and it will be integrated in the core of Capella in Q1 or Q2 of 2018.
The address for the add-on was given in the slides:
https:// hudson.polarsys.org/capella/job/capella-master/lastSuccessfu lBuild/artifact/releng/plugins/org.polarsys.capella.richtext .site/target/repository/
You need to download this and install it in the dropin folder of Capella. Let us know if you have a problem doing that.

Hi Stephanne
Thanks. Its OK now. Minor comment: some icons seems to be not present. See screenshot.
Regards
Arun

What is your environment, Windows or Mac? I’ve had this issue on Mac.
(this might be one of the reasons why it is still an add-on and is not yet fully integrated).
The buttons on the right side are buttons to create links. The one on the left side is a toggle to switch between edition and visualization.

It is Windows 10.

Looks like the team is already aware, but it does not seem to be systematically reproducible.
See
ticket 1880

Hello,
I can´t get it working this way.
I copied the files (structure from the zip-file) from
https:// hudson.polarsys.org/capella/job/capella-master/lastSuccessfu lBuild/artifact/releng/plugins/org.polarsys.capella.richtext .site/target/repository/
into the dropins directory of capella-1.2.0. I don´t see any RT-Editor…
The link from the slides
Update site:
http://download.polarsys.org/capella/core/updates/releases/1 .2.0-R20171103-050121/org.polarsys.capella.richtext.site/
is not working for me - due to a firewall.
How can I get the RT-Editor working?
Kind regards

We have the same firewall issue in our company
Unfortunately the Polarsys Hudson infrastructure does not seem to be working tonight and I cannot find proper links.
If you’ve been able to download the files from the link I gave previously and the dropping option does not work, you should be able to install it via the update site mechanism.
In Capella, go to “install new software” as if you wanted to install form a remote update site. There, you can create a local update site (either pointing directly to the archive file you downloaded either pointing to the extracted files. For an extracted local “update site”, my file system looks like that:
And then in Capella,
Sorry for all this hassle. I wish this component was already par of the core of Capella, but things sometimes take a bit longer than expected…

Hello,
I am trying to open directly an URL link with an https protocol :
I cannot open it.I use the addon with Capella 1.2.0 on windows 7.
Is that normal?
Maybe because the Capella’s Web browser cannot open https but only http (I tried and it worked).
Is it possible to set Internet Explorer as the browser by default?
Thank you,
Best regards,

Hello Ron,
To navigate to the target of link in Richtext, use right-clik on the link, then choose “Open Link” menu.
Capella uses embedded IE internal browser. May be you can change in Window -> Preferences -> General -> Web browser.
Regards

Ops, I understand your case.
In fact, this is bug :
ticket 2031
It will be fixed in the next release.
Regards

I seem to be having the same Rich Text trouble at described at the top of this thread with Capella 1.2.1. I have checked that it is installed, but there is still no available rich text widget. I’m running Windows 7.
Has anyone else seen this or have I made an error somewhere?

Which JRE version are you using ? Have you already tested it with JRE 1.8 ?

Yes I am running JRE 1.8.0_171

Hello,
two questions:

  • how to decrease a distance between text lines?
  • why there is a “save” icon needed and why “Finish” button doesn’t store the description?

Found a solution. It’s enough to edit following css file: In above case adding removes unwanted spacing between the lines:

This is the simplest example of the issue that I can provide:-
I am running Windows 7
I am using Java 1.8
I have used a base installation of Capella 1.2.1 with no updates from update sites or drop-ins
I have started a new project and added 1 logical component.
When I go to the description in the properties for the logical component I get the attached display, error message and stack trace:-

Can you please send us the full stack trace to analyze the issue ?
(double click your error message and copy all the stack trace)

I can reproduce the error. It happens only the first time when I go to the Description-Tab.
–> see log file

oops, I must have missed that I did not have the full stack trace there. sorry about that. I have attached my stack trace, it is similar to yours but not quite the same.
I can reproduce the error every couple of times I enter the description tab. However I can never enter a description and the Rich Text widget never works.
Thanks for your help!
The first difference is at this line:-
at org.polarsys.capella.core.ui.properties.richtext.sections.Di agramDescriptionPropertySection.refresh(DiagramDescriptionPr opertySection.java:145) in your trace whereas I get:-
at org.polarsys.capella.core.ui.properties.richtext.sections.Di agramDescriptionPropertySection.setInput(DiagramDescriptionP ropertySection.java:183)

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.