Release of XHTML Docgen v5.0.0 for Capella v5.0.0

Hello,

The XHTML DocGen 5.0.0 addon compatible with Capella v5.0.0 is available.
See the official release page for release notes, download links and the online IFE documentation example:

Regards

Good news… but I copied the file in the dropins folder, as usual… and no command appears in the rightclick menu.

I must have missed something… if you could give some check to look at
Thanks by advance

Thierry Poupon

Hello.

I just checked and it does appears on my install. Are you using Capella’s “Project Explorer” view ? The command will not show in the classical “Project Explorer” nor on the “Model Explorer” views.

Regards,
Arnaud

Hello
I’m using mainly the standard perspective of Capella: so the tree view on the left is called Project Explorer… What do you call classical project explorer: standard Eclipse project explorer?
Then I suppose that my tree view is the correct explorer…
I still try to look to other views available…
Thanks
Thierry
Ok I have found Eclipse explorer and Sirius model explorer… So My normal use is Capella project explorer.
Still: I working on migrated model from 1.4.2, and I’m still offered migration commands… despite the migration was completed
Another question: what is the command convert to modeling project (configuration)?

Ok thanks for this.

Can you check your install and ensure that the docgen is well installed ? Maybe your install went wrong for some reason. You should have the following:

Still: I working on migrated model from 1.4.2, and I’m still offered migration commands… despite the migration was completed

Indeed me too. This may be a valuable feedback to the Capella developers.

Another question: what is the command convert to modeling project (configuration)?

This command add some “Natures” to the project. Natures activates some specific behaviors on projects, for example additional builders or compiling behavior (java nature for example), additional tools…

Hi Arnaud
I just checked again I do have the same list with “(incubation)” at the end…


Thanks

Hi Thierry,
I think you have to check what is going wrong with your Capella launch.
Did you tried:

  • add “-clean” flag in the start command of Capella ? (modify the shortcut to add this)
  • launch in a new workspace ?
  • launch Capella with the “-console” flag. When Capella is launched go to the command window and type “lb docgen”. This will list the bundles that are installed and give their state. For me this gives:
   ID|State      |Level|Name
  716|Starting   |    4|HTML Documentation Generation - Capella (Incubation) (5.0.0.202012170838)|5.0.0.202012170838
  717|Starting   |    4|Html (Incubation) (5.0.0.202012170838)|5.0.0.202012170838
  718|Active     |    4|Capella HTML Documentation With Configuration - UI (Incubation) (5.0.0.202012170838)|5.0.0.202012170838
  719|Starting   |    4|Capella HTML Documentation Generation With Configuration - Command Line (Incubation) (5.0.0.202012170838)|5.0.0.202012170838
  720|Starting   |    4|Capella HTML Documentation Generation With Configuration - Edit (Incubation) (5.0.0.202012170838)|5.0.0.202012170838
  721|Starting   |    4|Capella HTML Documentation Generation With Configuration - Editor (Incubation) (5.0.0.202012170838)|5.0.0.202012170838
  722|Starting   |    4|Capella HTML Documentation Generation With Configuration - UI (Incubation) (5.0.0.202012170838)|5.0.0.202012170838
  723|Starting   |    4|Capella HTML Documenation Generation - Preferences (5.0.0.202012170838)|5.0.0.202012170838
  724|Starting   |    4|Capella HTML Documenation Generation - UI (Incubation) (5.0.0.202012170838)|5.0.0.202012170838

If it is not “Active or Starting”, then be sure that you have a Capella session opened. For me when I do a right click on the .aird file then bundle 724 state goes to “Active”.
If it is (not listed) or (it is not “Active” or “Starting”), then there is a bigger problem. Probably a conflicting dependency. Do you have any other addon installed ?

Arnaud

Hi Arnaud,
Thanks for your answer… but I don’t understant : I just activate an exe file to start Capella application, or use a windows shortcut to find it… Where should be the flags?
Thanks
Regards
Thierry Poupon

Hi Thierry,

Sorry about the lack of details. You have to create a shortcut for your “.exe” file and in the shortcut properties add the " -clean" after the path to your “.exe”.

Arnaud

I have some new information: I download same set up on my personal computer. There it works. The difference is that on my personal computer I’m the admin, not on my work computer. So I have requested short term admin rights to run Capella as admin once.
I think I have never done it with the add on, and I had to do it at first to run Capella without a warning stop for unkown software source.
Keep you informed
Regards
Thierry Poupon

Hi Thierry,

Thanks for the update. I will investigate this on my side but admin rights should not be necessary to run Capella with or without XHTML DocGen.

Regards,
Arnaud

Hi Arnaud
Ok I manage to run as admin: no difference. My plan was to do it once to see if something occurs
Now I double check by running again as user: nothing new…
Other interrogation would be authorization ti use jar files, but I think they are already necessary to run the application itself.
Thanks for your time
Thierry

To be honest I did not find the way to add the “-clean” in the path of my shortcut…
Windows just says the path does not exist with. I did not find any box to check for this anywhere in the shortcut properties either.
If you could share a screenshot…
Many thanks

Thierry

Hello,

I can confirm you that you need to execute “some” jar files to run the platform so this is not the problem.

About the " -clean", you need a space between the capella.exe path and “-clean”. Here is a screenshot.

Regards,
Arnaud

Ok here is the result after running with the clean extension


Still do not appear in menus
Thanks for your new ideas

Hi,

Your install seems OK. So this is probably a problem with an activation of a plugin.
I see that my previous indications (in the third bullet) are not correct. Please try the following:

In your Capella, open the “Console” view (and not Command as I stated int he previous message) and open the “Host Osgi console”


Then in the console type: lb docgen
Can you post the result of the execution of this command ?

Regards,
Arnaud

Hem…
The point is that I don’t have anything but open console view… so I can’t type anything in the host OSGi
Something is missing in my setup?

Thanks

Thierry

… Sorry, my bad.

You have to activate the “Development” capabilities in the preferences:

Regards,
Arnaud

Here is the result:

osgi> lb docgen
No matching bundles found
osgi>

Regards
Thierry

That is quite strange.
So the lb command should retrieve all bundles from your install.
Please verify that this command returns something.

In your “Capella Installation Details” windows, can you go to the “Plugins” tab and check if “org.polarsys.capella.docgen*” plugins are present ? (In your message you show the list of features). But features being here, plugins should also be here.

Regards,
Arnaud

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.