Migrate to 5.0.0

Hello
I’m trying to migrate a model from v 1.4.1 to v 5.0.0, but the migration command in the menu does nothing… I have check that additional the view are unchecked in orginal model.
(Some are white or grey…)
I don’t understand what’s wrong

Hi Thierry,

Could you be more specific on the faced issue?
From my side, I was able to migrate few models using the usual command (right-click on the project -> Migration -> Migrate project toward current version) without any problem.

Yes: I checked that migration tool is enabled, then bring the file in the workspace by import command, then: migration applies only on aird and capella files, so separately, but do nothing.
I clicked it for both but notheing happened.
About view points, some are installed in my 1.4.1, but the model I’m trying to migrate is not using them…

Thanks for your time

Hi Thierry,
First of all, I am unsure if you should first migrate from 1.4.1 to 1.4.2 first, but let’s forget this for now as you have another issue first.
Please note that if you migrate to Capella 5.0.0 then you will not be able to go back to 1.4.x with your model.
First, I think you should apply the migration tool to your project folder, not on each file individually. Please make sure you have saved your project before.

Second, and more importantly, you are using add-ons/viewpoints. The fact that your model is not using viewpoints does not matter, if they are installed, your model is referencing them. You have 2 options here:
1 - you need to make sure that you have the same set of viewpoints in your Capella 5.0.0 or the migration won’t work
2 - or you need first to go back to Capella 1.4.1 and detach your viewpoints from your model before importing it in an empty Capella 5.0.0 (see the appropriate documentation for this, I think there is a section around Viewpoints Detachment in the KitAlpha section maybe)

I hope this helps.

Stephane LACRAMPE
Obeo Canada

Ok my next try would have been to run a new Capella 1.4.1 without the non used view points, as this was what understood about detachment… Currently the models has all additional view point unchecked.
Thanks
The reason why I did not on the folder is that the command was not in the right click menu there…

Some updates: I have deleted addons, restart the project, exported as archive and reimported in version 5, and the migration still not work… with the same issue:
First try at folder level says tool not enabled, and then the migration command disapears from the right click menu there, and below, the command is still there but does nothing (on aird and capella files)
Last one would to migrate first to 1.4.2… but may I ask about Java: now Java is integrated, so there are two Java on my PC, same version or not: may this cause the issue? The point is I’m quite sure I need my other Java for other corporate applications…and my current capella 1.4.1.
Thanks for your return.

Hi Thierry,
Deleting the add-ons and restarting the project will not remove the dependencies from your models to these add-ons. You need to detach your model from these add-ons first. Look for “Model Detachment” in the documentation, there should be something about it.
I hope this helps.
Stephane

This is the next point: I can’t find in Capella 1.4.1 detach command, I have only the boxes to check uncheck when there are addons in…
Should I do it from v5 before migrating?

No model/viewpoint detachment should be done within the project you start from, let’s say in Capella 1.4.1 if you start from here.
You should look for this page in the Capella documentation:


I hope this helps
Stephane Lacrampe
Obeo Canada

Hi
I have saved, unchecked all missing viewpoints in target version (5.0.0), resaved and exported, then removed addons, relaunch, open the model tree in 1.4.1: not found any detach command, closed
launch v5.0.0 detached aird, some computation has been done, and then

  1. apply command migrate to project folder: “not enabled”, no retry possible command desapears from menu.
  2. Apply to melodymodeler: nothng happens
  3. Apply to aird nothing happens
    Thanks for your time

I do not understand why you are starting in Capella 5.0.0. The first steps needs to be done in the Capella version you are starting from, Capella 1.4.1.
If you could share a small model (maybe deleting almost everything from your model in Capella 1.4.1) where you still have the issue, I could try to reproduce you problem and give you the right steps to migrate it. Or obfuscate one of your model (after having saved it somewhere before launching the obfuscation)
Stephane

Sorry for misunderstanding: I unchecked all viewpoints that are missing in 5.0.0 in 1.4.1 -in fact all addons- prior to do everything, and continue all my steps in 1.4.1 until reimport in 5.0.0.
If I had found the detach command in 1.4.1, I would have use it, before exporting…
I think I’ll manage to duplicate and obfuscate… My model is currently in the middle of system analysis step, and having some rework back in operational analysis, so a quality check may raise many concerns. Could this bring some causes?
I double checked: in preferences (5.0.0), the migration commands are all checked.
Thierry

Hi Thierry,
From what I understand, the problem you have is that the migration command in Capella 5.0.0 does nothing.
I do not see any reason for that, including the status of your model. The only thing is that your session needs to be closed before launching the migration.
Stephane

Hi Stephane,
I understood the issue:
I imported the model from archive, which leads to get an empty model on top of the one you are importing. (I have to manage to solve this and eliminate the empty model and the non used folder levels). The file in .project is only at the top level, and needs to be in the migration scope. If I migrate everything, it works.
Thanks for your time
Thierry

PS May be you can tell me the easiest way to bring my import at the root place in the tree…I remember now how to avoid it, but I need to repair my situation.

Personally, I usually don’t use the import/export function, I tend to copy files/directory, but I am not sure this is a good practice…

Hi Stephane
I have been too quick: migration process still terminate with another error… about file organization, and too old version… So I tried to reduce the useless folder levels, but then transitions do not work any more because the links are not modified. I have understood as well that I need to have the file.project in my import scope. But now I’m back with an immediate cancellation of any migration attempt. I even tried to first migrate to 1.4.2: no migration command visible in 1.4.2 workbench, but it opened my 1.4.1 project without loss.
Then I reexport, import in 5.0.0, same result: project migration cannot be enabled, disables when activated, aird migration immediately cancels.
I start to think to forget version 5.

Update: I continue to explore: My model 1.4.1 has the migration command in 1.4.1! The process stalls because diagram styler is out, and filtering… In fact I can migrate a new fresh project: I created a test project, then I saw in same wb 1.4.1 the migration tool…I activated it, and it produced a migrated project. This test project migrates to 5.0.0. But was never in contact to diagram styler neither filtering.
My understanding is that for some reason there is no way to detach these two addons from my model, despite my 1.4.1 is without and runs it. I can restore for 1.4, but I think they are not yet ready for 5.0.0?
Thanks for any idea

2nd update: I finally manage to find how to make appear the detachment tool in wb1.4.1: all session have to be closed and rightclick on aird… So I could get rid of diagram styler and filter
So I manage to migrate to a 1.4.1 as migration was proposed, then to 1.4.2, then using still the same project, copied the file to 5.0.0 workspace and opened there: migration still cancels.

Any error in the error log?

I just retried now same file, same result: here is the log text:

!SESSION 2021-01-28 07:26:16.537 -----------------------------------------------
eclipse.buildId=unknown
java.version=14.0.2
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.emf.validation 2 70 2021-01-28 07:26:40.979
!MESSAGE Constraint “org.polarsys.capella.transition.system2subsystem.multiphases.HW_01” could not find target EMF type “LogicalFunction.”

!ENTRY org.eclipse.emf.validation 2 70 2021-01-28 07:26:40.979
!MESSAGE Constraint “org.polarsys.capella.transition.system2subsystem.multiphases.HW_02” could not find target EMF type “PhysicalComponent.”

!ENTRY org.eclipse.emf.validation 2 70 2021-01-28 07:26:40.987
!MESSAGE Constraint “org.polarsys.capella.transition.system2subsystem.multiphases.HW_03” could not find target EMF type “FunctionalExchange.”

!ENTRY org.eclipse.emf.validation 2 70 2021-01-28 07:26:40.989
!MESSAGE Constraint “org.polarsys.capella.transition.system2subsystem.multiphases.HW_04” could not find target EMF type “ComponentExchange.”

!ENTRY org.eclipse.egit.ui 2 0 2021-01-28 07:26:56.549
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: ‘H:’. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

!ENTRY unknown 8 1 2021-01-28 07:27:25.652
!MESSAGE

It’s true that this project has not yet any logical; physical or end item…but I did not remove any root folder there.
Thanks for ideas
Thierry

Is it possible for you to share your model with me?

I have found the issue: the project, melodymodeler, aird and afm files have to be in the same folder, and may be are required to be at the root level.
As said, some import I have done introduced subfolders levels in mine.
I exported my model and reimported it in a fresh one. Then I compared both models the fresh and the imported to merge (as model) the model items in the fresh one.
My point is that I can’t merge diagrams as well.
But, if I export again, and unpack in Capella 5 workspace, I can import the new model, and then migrate.
So the question is now how to migrate diagrams: I have more than 384000 graphical items, I can don some of the route by portions, but at one moment, Capella (it’s 1.4.2 then) is out of memory, so I have to terminate and restart. Despite saving between each step,I’m back with my no diagram model.
I ran the compared as model because compare gives memory overflow.
The biggest diagram I have seen is the main OAB (not showing links, but all activites allocated to all OEs) which contains about 11000 graphic items.
Should I close the WB betewwen each merge step?
Is there another process to move back my model files at the root level where the project file is?
Thanks for any answer
Thierry

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.