M2Do 3.2.1 : zombie copies in teh generated document

Hi,

teh attached template generates an document, which cannot be opened (pls see the error pop-up dialog) although the validatipon/ generation was successful. It contains zombie copies of part of the m2doc template syntax.

BUG_ZombieCopies_minCardMaxCard.docx (16.6 KB) ErrorAtOpeningGeneratedDoc

The AQL Interpreter only shows 2 real properties - 2 table rows are generated.

Do you have any error in the Eclipse error log view may be with a stack trace ?

Also if you select the Capella token in the template properties wizard, you can then use the getValue() service and many others:

....ownedMinCard.getValue()

It return a String representation of the passed element. That can be a easier to use than creating your own template.

No, as I have written, the generation is successful and does not leave any error in teh Capella Error Log.

And an error occurs when trying to select the Capella package in teh Template Properties.

Can you try to create a new Word document and copy the content of your template into it and check if you have se same errors ? I think your Word document used as template might have something that prevent POI to read/write it.

What version of MS Word are you using ?

It is Office 2010. An it is a Capella team project - is this may be a problem?

The template is quite large and worked for quite a long ok except of when this writeMin/MaxCard methods were introduced. Almost identical methods writeMin/MaxValue work ok, though.

I am not able to clone the template: I have created a new Templale (New -> Other -> m2doc Template), copied the contents of our template into it and then I had to set the nsURIs again (I have set all polarsys and sirius ones) and also all the types of the template variables. At the end, when saving it, an error popped up. (It is very tedious to have to set all properties from scratch, therefore I don´t like to do it again. The whole business of nsURIs shoudl be hidden from the user anyway… and there should be a meaningful “copy template” function,)

Selecting the Capella token should add all needed nsURIs (except for specific Capella addons).

I tried to reproduce the problem (Capella 5.2.0 and M2Doc 3.2.1) on IFE templates and on the document attached in your first message and I don’t get any error.

When you edit the template properties with the wizard, you need to make sure the template is not opened somewhere else. Maybe that the source of this error.

Also do you have a full stack trace ?

Problem solved. I was able to clone the the template and it works now (indeed, the template doc was open in an editor and after closing it I was able to select the Capella package which sets nsURIS and Services automatically and I was also able to set the variable types). No idea what caused the issue in the first place. Thanks!

That’s a good news, I think the previous issue will be also solved with this change.

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.