Links on the Documentation tab

Watching again the Capella Tutorials on youtube I noticed the presenter used links in the Documentation tab of the Activity Explorer to navigate by the elements and diagrams of the level crossing traffic control model. (each link was clickable in Capella and it opened the linked diagram/element.
I tried to create these links in my models with the link tool in Capella Documentation tab editor but it doesn’t seem to work, it does not generate clickable links.
I also tried to import the level crossing traffic control example model from Capella site to check if the links from the presentation were present and the texts that had links on them were all in black (not highlighted as hyperlinks) and not clickable.
Is this feature disabled somehow? If so, how can I enable it?
I have XHTML export, PVMT and the Requirements viewpoint add-ons installed.

Watching again the Capella Tutorials on youtube I noticed the presenter used links in the Documentation tab of the Activity Explorer to navigate by the elements and diagrams of the level crossing traffic control model. (each link was clickable in Capella and it opened the linked diagram/element.
I tried to create these links in my models with the link tool in Capella Documentation tab editor but it doesn’t seem to work, it does not generate clickable links.
I also tried to import the level crossing traffic control example model from Capella site to check if the links from the presentation were present and the texts that had links on them were all in black (not highlighted as hyperlinks) and not clickable.
Is this feature disabled somehow? If so, how can I enable it?
I have XHTML export, PVMT and the Requirements viewpoint add-ons installed.

2020-07-06 15_43_34-workspace - Level Crossing Traffic Control - Capella.png
2020-07-06 15_43_34-workspace - Level Crossing Traffic Control - Capella.png

Hi Fabio,
This is a very standard feature of Capella. I can see to things:

  • Have a look at this thread:
    https://polarsys.org/forums/index.php/mv/msg/946/3582/
  • And also: You may have to “Unblock” this file: capella\eclipse\plugins\org.eclipse.nebula.widgets.richtext_1.2.0…\org\eclipse\nebula\widgets\richtext\resources\template.html (see the image attached).
    Let me know if it fixed your issue.

unblock.png
unblock.png

Hi Fabio,
This is a very standard feature of Capella. I can see to things:

  • Have a look at this thread:
    https://polarsys.org/forums/index.php/mv/msg/946/3582/
  • And also: You may have to “Unblock” this file: capella\eclipse\plugins\org.eclipse.nebula.widgets.richtext_1.2.0…\org\eclipse\nebula\widgets\richtext\resources\template.html (see the image attached).
    Let me know if it fixed your issue.

Hi Stephane, thanks for the answer!
I tried moving my Capella installation as close as I could to the root: C:\guarita\Capella
But it didn’t solve the problem.
I checked the file and it doesn’t seem to be ‘blocked’ - I guess that’s a feature of a newer version of Windows, I’m still in windows 7 and the ‘unblock’ checkbox is not available to me in the file properties dialog.
I tried another installation I have of version 1.3.1 (the one I use most is 1.4.0) and it doesn’t work.
I checked the Error log and found the error below happening on Capella startup:
“Unhandled event loop exception”
Stack trace:

Hi Stephane, thanks for the answer!
I tried moving my Capella installation as close as I could to the root: C:\guarita\Capella
But it didn’t solve the problem.
I checked the file and it doesn’t seem to be ‘blocked’ - I guess that’s a feature of a newer version of Windows, I’m still in windows 7 and the ‘unblock’ checkbox is not available to me in the file properties dialog.
I tried another installation I have of version 1.3.1 (the one I use most is 1.4.0) and it doesn’t work.
I checked the Error log and found the error below happening on Capella startup:
“Unhandled event loop exception”
Stack trace:

There is probably a configuration problem somewhere but I don’t know where. What is the java version you are using?

There is probably a configuration problem somewhere but I don’t know where. What is the java version you are using?

java -d64 -version returns me:
My Capella installation details page has this configuration key:

java -d64 -version returns me:
My Capella installation details page has this configuration key:

Hi,
Can you try with latest 1.4.1 stable version ?
https://github.com/eclipse/capella/releases/tag/v1.4.1-S20200630
We have fixed a issue where sometimes, click on a link in description doesn’t open the diagram but display an error popup message.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=564411 /
https://github.com/eclipse/kitalpha/commit/f1ab31b0eecff53e734dcadc4b716876e8900d70
It occurs in collaborative models using Team for Capella but it may occurs in other cases i guess.
Best regards
Philippe

Hi,
Can you try with latest 1.4.1 stable version ?
https://github.com/eclipse/capella/releases/tag/v1.4.1-S20200630
We have fixed a issue where sometimes, click on a link in description doesn’t open the diagram but display an error popup message.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=564411 /
https://github.com/eclipse/kitalpha/commit/f1ab31b0eecff53e734dcadc4b716876e8900d70
It occurs in collaborative models using Team for Capella but it may occurs in other cases i guess.
Best regards
Philippe

I’ll try it but in my case the links are not even ‘clickable’. They are displayed as normal text. Actually what it feels like is that the editor creates the text but there’s no link information behind the text.
Even the sample project of the Level-crossing Traffic Management which I know has a documentation tab full of links, is displayed without the highlights.
I’ll check version 1.4.1 and come back to you on this. (hope final release comes out soon, I’m expecting the correction on the LA to PA transition of Logical Components…)

I’ll try it but in my case the links are not even ‘clickable’. They are displayed as normal text. Actually what it feels like is that the editor creates the text but there’s no link information behind the text.
Even the sample project of the Level-crossing Traffic Management which I know has a documentation tab full of links, is displayed without the highlights.
I’ll check version 1.4.1 and come back to you on this. (hope final release comes out soon, I’m expecting the correction on the LA to PA transition of Logical Components…)

You may also want to give it a try with this Java version: 1.8.0_121_64b

You may also want to give it a try with this Java version: 1.8.0_121_64b

Hi, just tried with Capella 1.4.1 and it doesn’t work…
I can’t try Java 1.8.0_121_64b on my company computer because only releases provided from our internal IT guys are allowed. And that is enforced by rules on windows so I can’t even try to install anything…
I installed Capella 1.4.0 on my personal notebook to check and it didn’t work there too. My Java version is 1.8.0_45-b14
I couldn’t find Java 1.8.0_121_64b for download for my personal notebook. I’ll try tomorrow then come back with the results.
Thanks for the answers.

Hi, just tried with Capella 1.4.1 and it doesn’t work…
I can’t try Java 1.8.0_121_64b on my company computer because only releases provided from our internal IT guys are allowed. And that is enforced by rules on windows so I can’t even try to install anything…
I installed Capella 1.4.0 on my personal notebook to check and it didn’t work there too. My Java version is 1.8.0_45-b14
I couldn’t find Java 1.8.0_121_64b for download for my personal notebook. I’ll try tomorrow then come back with the results.
Thanks for the answers.

Hi Fabio,
You should be able to find the right java version here:
https://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html
Stephane

Hi Fabio,
You should be able to find the right java version here:
https://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html
Stephane

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.