DOORS 9.6 - configuring the ReqIF export for Requirements Add-In

I have been able to generate an ReqIF file in DOORS 9.6 but on import into Capella using the Requirements Add-In no requirements are created. I am sure that the ReqIF does not have all the mandatory information but I am not sure how to ensure that the correct ReqIF data is generated by DOORS.

Update - I was able to import a ReqIF file generated from DOORS 9.6 into Capella 5.0 using the updated Requirements Add In. However as the ReqIF file doesn’t contain a PUID field how can I show the requirement ID in the Requirement Label? The DOORS attribute containing the Requirement ID is named “documentKey” .

Hi Nick,

The labels in diagrams can be changed through this window:

The labels in the treeview can be changed in Window > Preferences > Capella > Requirements

You will have to change the AQL expression to get your fidel "documentKey’ instead o ‘IE PUID’.

You will find more info in the embedded documentation: Requirement viewpoint guide -> User’s guide -> preferences, and -> Requirements in diagrams.

Stephane LACRAMPE
Obeo Canada

Hi

Many thanks Stephane. I tried what you suggested but it had no effect.

I notice that the attribute ‘documentKey’ has not been included into the Semantic Properties of the Requirement (see image) but it is defined in the Types view in the Project Explorer (see image) - is that why its not accessible? Any thoughts?


Cheers

Nick Harris

Hi Nick,
Maybe something is missing when you do the import, maybe it has to do with the way you configure the import, but I am not sure as I am not too familiar with this import.
Is your “Requirement” of type “Capability Need”?
Stephane Lacrampe
Obeo Canada

Hi Stephane

The requirement type is Capability Need but I assigned that label to the Requirement within Capella.

Cheers
Nick

Hum, Not sure I get it. Could you share a very small model extract with me, maybe with just one requirement?

Hi Stephane

I have attached a screenshot of one requirement linked to its corresponding operational capability. The Type on the left was created during import but I renamed the blank requirement label “Capability Need” in Capella.

The corresponding properties for the imported requirement are shown in the next screenshot.

The next screenshot shows the Semantic information for that requirement:

Can you show me how your requirement looks in the project explorer, if it got a documentKey attribute?
If it does not have a documentKey attribute, can you confirm you can add this attribute by right-clicking on the requirement?
From what I see, there is a problem with how your object attributes in your ReqIF files are mapped to the created requirements. I do not know well this part of the add-on, ie how to configure the mapping, there is something on this in the embedded documentation and you may also have a quick look at this thread: [Requirement] Importer Preferences

Stephane

This is how the requirement looks in Project Explorer - there are no attributes

I right clicked and created a string value attribute “documentKey” and the view in Project Explorer changed to

The problem described in the link looks similar so I will try and set up a text file defining the import mapping and see how that goes.

Cheers
Nick

Great.
So creating one attribute manually will enable you to check that you did what’s necessary to have documentKey displayed in diagrams (and also the treeView if you want).
But in the end, it looks like the mapping needs to be worked out indeed!
Stephane

Hi Stephane
I have a question for you regarding this process.

  1. I have created a properties file but not clear as to the syntax for attribute name… referring to the help in the example what does ‘Requirement’ refer to and do I need to change that to something in my specific import file? I used this notation with “Requirement\ documentKey:true” and although documentKey appears in the importer page there was no change to the project data following the reqIF import.

image

Not sure how this import configuration file works as I never used it.
Does anybody can help here?
Stephane

Hi Stephane

I got some help from marieme who raised the problem you sent the link to and the solution was very simple. I had tried to over complicate things. The answer was just to use “documentKey” as the attribute name!

Cheers
Nick

ok so you got it all working now?

Yes - the data is importing correctly now.

That’s great to hear! And can you display the documentKey in your diagrams as well?

Yes - the diagrams show the documentKey in the diagram title.

ok great I am glad to read this.

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.