Capella Studio First Experience - Help

I am taking my first steps with Capella Studio. Using this post to:
a) ask questions where I get stuck
b) documenting the process for anyone else getting started. Hope this helps.

I am a System Engineer, not a software developer. But giving this a go!

I downloaded from here: Eclipse downloads - Select a mirror | The Eclipse Foundation

Once downloaded, I went to extract the zip file. First problem was after the 30mins it took to extract, the file path for some of the files was too long. Easy fix… shorten the file name of the “capella-studio-” folder.

Next challenge… I clicked on the eclipse application. I then got this error:
JVM Error

I went to this java website to and downloaded then run… the x64 archive.
Java Downloads | Oracle United Kingdom. Still the same error.
Then I tried this…
Then I tried this… Java Archive Downloads - Java SE 11 | Oracle United Kingdom

So question #1… how do I get the right JVM?




Check the following topics:
Installing Capella vs Capella Studio and the need for JMV - Capella - Eclipse Capella Forum (
Capella Studio 6 and higher are (not free)? → Java 11+ is not unfortunately - Capella Studio & Kitalpha - Eclipse Capella Forum (

So basically just download a JDK from JDK Java Net and add it to the PATH environment variable of your system. I recommend a JDK older than JDK 17 (Like JDK 11 or 16) because of a deprecated feature (Ant SecurityManager) that won’t allow you to build stuff.

Thanks for the help @mvccogo however you might need to step me through this a little more.

I have downloaded JDK, and you can see I have got 11.0.17 as you recommended.

Then I went to my Advanced System Settings to set the PATH environment variable.


Currently that looks like this. I set the JAVA_HOME and the PATH as the same folder name, in both the system and user variable. There were a bunch of different paths in the system variable, separated by a ; therefore I added it to the start finishing with another ;.

But I am getting the same error still. Any idea why? Where have I gone wrong?

Thank you very much :slight_smile:


Hi again Josh,

You just forgot to add “\bin” at the end of the folder. So inside “Path” (which you can expand if you want, it will show a few rows containing entries instead of a single line), it should be
“C:\Program Files\Java\jdk-11.0.17\bin” (with “;” at the end if you are editing it without expanding).

1 Like

Success! @mvccogo Thank you for taking the time to explain this. :slight_smile: :slight_smile: :slight_smile:

I will now continue my explorations.

Including for future forum searches: “Version 1.8.0_161 of the JVM is not suitable for this project. Version: 11 or greater is required.”

I got the JDK version 11 from here: Java Archive Downloads - Java SE 11 | Oracle United Kingdom

1 Like