XHTML Documentation Generation issue

Happy new year to Capella users!
I tried to switch from Capella 1.3.1 to Capella 1.4.0 and I installed the workbench together with Requirements, Price, Mass, Perfo VPs and Transition, XHTML, and Filtering extensions.
After the model upgrade everything seems fine with editing operations, but I got an error while generating XHTML documentation.
I am attaching the log file.
Thank you for your support.

Errorlog.txt
Errorlog.txt

Hi, and happy new year to you too !
From what I see in your log file it seems that you have an outgoing allocation link from a requirement to a null object. Would it be possible that your model contains such a dangling reference ? Deactivate the “Requirements VP Relations” filter in the Project Explorer and look for relations like the one highlighted in the attached screenshot.
Regards,
Arnaud

2020-01-10 12_09_13-Filters and Customization.png
2020-01-10 12_09_13-Filters and Customization.png

Hello,
I had the same issue some days ago. It was some requirements links that hadn’t got any targets. I deleted all of them and the exports worked fine! I have not understood yet why I had links with empty targets…
Best, regards!
Jean

I have an issue generating html documentation: the routine does not complete in 1.3.0 version (I kept models there to continue to use the eclipse clipboard), even after solving all conflicts seen by validation tool, except realization issues (So far only OA is populated). Then I tried to migrate, (revalidate and solve) The export tool completed its routine but no picture is available in the documentation. At the moment, I don’t use requirement objects, but I still use activities; entities, exchange items and elements, types of all kinds; property values and groups… My diagrams are OAIB; OAB; OAS; OES; MSM; OCB…;
I cannot share any file for confidentiality issue, but if someone has an idea…Thanks
Edit: Capella 1.4.0 does not produce any picture export at all, even using the camera tool from the workbench. I tried jpg and png.
Removing all descriptions does not help (I had issues to solve there about “;” missing at the end…)

Hi,
I have the same problem reported by Pier Giorgio. The generation of the XHTML documentation stops and an error is returned (see the attached log).
I followed Arnaud’s suggestion and now all of my requirements are linked to exisisting objects.
However the problem persists.
I noticed that there are two validation rules related to requirements (i.e. REQ_Relation_01 - Null relation type check and REQ_Relation_02 - Unique relation type check).
I guessed that they could help finding bad relations but when I check the model validation I get no errors related to such validation rules.
Do you have any ideas?
Thank you for your support.

xhtml_error.txt
xhtml_error.txt

Hi
The point was solve by migrating to 1.4.1. I suppose Java was in advance compared to Capella (1.3.0) and happened to be only partially compatible.
Thanks all
Thierry

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.