Whitespace in diagram (OEBD)

I have experienced an unusual behaviour in Capella with one of my OEBD diagrams.
At some point after saving the model whitespace has been introduced to the left of the OEBD diagram.
There is no obvious elements or objects in this whitespace.
Tried to move all the elements to the left into the whitespace area but the whitespace seems to be always there. The knock-on effect is that when I generate an image from this diagram, the whitespace is included.

Has anyone else experienced this? Any suggestions on what to check?

2 ideas:

  • did you try to do a “reset origin”? (right click in the background of the diagram)
  • Do you have some hidden element in your diagram?

Hello Stephane,

I tried the ‘Reset Origin’ option prior to your suggestion, but that didn’t work.

Regarding hidden element, I didn’t have any filters enabled to actively hide any elements.
So just tried some options and finally hit ‘Visibility Mode’. I changed from ‘Standard Mode’ to ‘Visibility Mode’ and could see little OE squares and one was on the far left (see screen shot), not visible in Standard Mode.

This is what caused the issue.

When I click on the OE square it actually seems to be linked to the ‘Contained In’ connection. The properties show it to be an Operational Entity.

The properties of the little OE square:
Not all Contained In lines have these OE squares beside them but they are on the diagram in different locations. So it seems like as I moved elements around to position them the little OE squares got left behind in the original positions. (I’m guessing? )

Thank you for the hint to dig a bit deeper in this direction.
The issue is solved :slightly_smiling_face: but I am still baffled as to the root cause why this would happen in the first place :confused:.

At least now I know where to look if this issue occurred again in the future.
Thanks again.

1 Like

Hi, yes
To quickly see if there is some hidden elements in the top left, you can use the “Visibility Mode”.
Some elements might appear translucent.


2 min late ^^
Good to know you fix your issue

Thanks Philippe… I learned this today the hard way :smile: