Use of Libraries

Hello everyone,
I tried to start working with libraries, and have to cope with a little issue.
I created as an exemple a librarie ‘Dog’, with elements in Logical Architecture and in Physical Architecture.
I want then to create a REC from the whole librarie content. The REC menu creation warns me that "REC have references to external elements ; Please specify if your REC elements are suffixed’, which I don’t clearly understand.
I then create a new librarie ‘pack of Hound’, in which I want to create two RPL of the previoulsy created REC.
The creation is however impossible, I attach the picture of the RPL creation menu thereafter.
What can be the trouble here ?
regards,

An other problem that I faced : I have short-circuited the previous problem by removing a few problematic elements from the REC. However, event if the RPL menu seems allrigt, the RPL is never created in the new library…

Hello,
Could you send your sample model to have a closer look at the issue you have?

It is a very simple model : I cretaed three logical components, three functions, two Physical component. I also made an automatic transition of Functions and behavioural nodes.

It is not possible to open your model with just the aird file.
You need to provide all different files of the project (aird, melodymodeller, afm and .project).
The best is to create an archive with the project folder and its content

Here it is !

Hello,
Well there is indeed something wrong with the command “create a REC from the whole library content”.
Some elements are missing from the definition of the REC.
In order to correct this, just select the REC in the library (the REC “chien”), and right click, REC / RPL, update REC, from selection.
In the next window, do not modify anything and press OK.
The missing elements will automatically be added (a diff / merge window open, press apply).
You will now be able to create a RPL from this REC without issue.
I will report this issue to the development team, and hopefully the command will be fixed in the next version of Capella.

Hello Aurélien,
I have tried to implement your solution, but it not worked as expected.
I updated the REC the way you told me to do, and then tried to instanciate a RPL in a new Librarie ‘Hound pack’ in which the library ‘Dog’ is referenced.
However, it was impossible to instanciate the RPL, as shown in the picture.
The problem seems to come from the [Part Deployment Link] from physical components to associated behavioural components.
regards,
Julien

Hello,
It’s strange. It worked well on my computer when I tried.
Have you well saved the library before trying to instantiate the RPL?

That was actually the problem… It worked fine !
Thank you very much Aurélien. Librairies seems to be a very powerful tool for reuse of components, it would be very helpful.
Regards,
Julien

Hi,
Please check the following Capella bug
ticket 2586.
This issue will be fixed in the next Capella version 1.3.2 and 1.4.0
Best regards,
Ali AKAR

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.