The version of capella for Python4Capella

Hello, what is the version of capella that i should used to work with the python4capella?

Thank you

Right now you should use ideally Capella 1.4.2, I believe it is working with Capella 1.4.x but the command line may not work with Capella 1.4.0

Stephane LACRAMPE
Obeo Canada

Another question in the installation they mention a metamodel (version 5.0.0), but they dont use that metamodel at all after importing it, is it important?

Thank you very much

I don’t see this in the installation section, can you point out which part you’re mentionning?
Stephane

In the section of ‘‘Capella simplified metamodel for Python4Capella’’ before the installation process

‘’ Python4Capella relies on a simplified metamodel in order to ease the definition of scripts by end-users.
This simplified metamodel is defined in a Capella model ( using Capella 5.0.0 ). ‘’

Thank you

So I don’t think this section is related to the installation of the plug-in. What this means is that Python 4 Capella provides a simplified way of navigated on Capella models, and that this “simplified way” is inspired by the metamodel from Capella 5.0.0 (ie the “simplified way” will be the same whatever Capella version you use, so the underlying code is taking care of mapping this simplified way with the Capella version you are actually using)
The bottom line is you don’t need to install this Capella 5.0.0 meta-model.
Stephane

Thank you very much for your help

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.