System to Subsystem fails

Hello,

  • I have a model with logical components inside my System.
  • I right click on this component to access
    System to Subsystem menu.
  • I choose
    Vertical SA.
  • I get a window to choose the targeted project and select options. I create a new project from this window.
  • I click OK. And then… nothing ! The new project has correctly been created but the Diff/Merge window does not appear. The new project is empty, it does not contain items from the original System.
    While doing this, I got the attached error logs.
    I precise that my Diff/Merge works correctly while using Git.
  • Capella: v1.2
  • System to Subsystem: v1.2.0
    Thank you for your help.

Hello
I am not able to analyze the logs myself, but I have forwarded them to the Capella development team.
I believe I know the answer, but would you be able to share your model (maybe by attaching an obfuscated version)?
Reminder: Capella provides a feature to obfuscate a model (this is a one way operation, so do it on a copy!!)

Hello,
Thank you for your answer.
I attached my obfuscated model, thank you for the tip ! I didn’t know that feature.
I try to make a subsystem from one of the logical components of this model.

I had the same issue with your model.
I’ve tried with the most recent versions of the add-on and of Capella and it seems to be fixed:
Capella 1.2.1 : http:// download.polarsys.org/capella/core/products/stable/1.2.1-S20 180601-102021/?d (will become official in 2 weeks)
Add-on transition 1.2.1 : https:// hudson.polarsys.org/capella/job/capella-addon-transitionsyst em2subsystem-v1.2.x/lastSuccessfulBuild/artifact/releng/org. polarsys.capella.transition.system2subsystem.site/target/
Would you be able to try these versions?

Thank you for the links. I tried this but it still does not work. I also tried with a new project from scratch, but same issue.
When I tried to create the subsystem, I simultaneously got several errors (see attached file).
Here are some details about my installation:
Ubuntu 14.04
MATE desktop
openJDK-8
Thank you again.

Update: I tried on Windows and it worked well. The problem comes from my Linux configuration (or the Linux version of Capella ?). I am not able to give more details, but I hope it can help some investigations…

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.