Scenario transition

Hi all
I’m experiencing difficulties to transition scenarios from OAS to OES: it doesn’t work until I remove all fragments…

The modeling context is a big model, for the moment, only OA is populated to define exact system context. (50 OEs, 200 OAs, close to 300 OCs, in which 180 shall carry scenarios, more than 1000 EIs, 500 states…)
The model was originated in 1.2.1 and migrated to 1.3.0, then to 1.4.1. My work session at my customer is migrating PC, Java is OK now, and the issue occurs on both PCs (Windows10 pro)

I tried to reinstall the application but it doesn’t work.

I can’t share my model due to confidentiality constraint.

Thanks for your ideas.

Some updates: in fact I manage to transition with only one fragment removed: the point is to find the one to remove…
During all my tries, another scenario was transitioned to OES (despite an OES was already set from an the OAS there, which Capella rejects normally…) All these OES are looking conform, but in fact the functions that included the correct OE lifelines are not correct!
It’s like if some of links were mixed in the model…

Hi Thierry,
Just making a few guesses here, but if you are using a fragmented model and removing one fragment solves your issue, then this may mean that your model is in an incorrect state, this may be due to some migration you did, or maybe issues when reconnecting some fragments that were modified by others… just guessing.
There is a way of sharing models with others while keeping confidential information by using the obfuscate tool.
But in any case, it looks lie your issue will require some investigation (maybe not much) that may fall into some professional services, let me know if you are interested.
All the best,

Thanks Stéphane,
Investigating, I wanted to check my extensions… and all folders under eclipse are hidden except Workspace . I could not choose another workplace, by the way…
It looks like I’m trapped by admin control in my organization.
Capella is not yet in official application list, the department where I am is doing a first application as PoC, try to push to officialize.
The point seems to come from OE and OE parts, and their representations in diagrams. The broken or unusable link seems to be the allocation…
My model has now 50 OE; close to 200 OActivities; 300 OC… (The organization discovers system engineering, I would even say the department where I am is pushing to introduce…)
I raise a ticket to IT in house to understand more about permissions

I just forgot: to make sure avoiding path length issues, I have shortened the folfer name having all the version data, because it was not possible to remove 2 useless folder levels. What happened is that Capella wanted its long name folder to set up workspace. I know where is my running copy (PC migration is sometimes complicated and full of incident that you need to keep in mind!)… I check the dropins!
Dropins has now all polarsys extensions… still not working.
Just in case here is the error reported:
pl.PartImpl cannot be cast to
PS: What called fragment is what Capella calls fragment: a block in scenario having one or several operands pending on a guard…

I’m currently completing the updating of OES by hand after OAS updating (15 of them are concerned). Just before another one, I tried a model validation:
None of the OE are referenced by a part
Previously I made visible the parts in the tree: their detail screen is the same than the OE instead of reference questionnaire (Refers to entity…) Issue level is Error.
Is my model totally fuck up?
I have no clue about apply a correction to this.
Thanks for any help.
Edit: I just removed 54 self generated entities named “entity” in the operational entities folder!
By the way, I need an explanation about why do I need to set constraint link when I use a constraint as guard in a operand, state transition or any other object, to my eyes it’s kind of repetition…
Thanks for all and any answer

Well, I am sorry, it is really difficult to see what is wrong with your model just using the forum. I am under the impression that the next step would be to try to reproduce the issue you are having, so that would invovle you sharing:
- the exact configuration you have (wich OS / Java version / Capella version/add-on installed)
- Share the exact scenario to reproduce your error
- Share an obfuscated version of your model
- share your .log files


Thanks Stephane, I just had a permission about sharing obfuscate model…
Just before, I have some news:
1/ My PC migration left hidden an issue about folder organization within dropins, which made unavailable some of extensions… Solving this made some progress, but it’s not closed
2/ New progress by duplicating common constraints used as guard in operands belonging to different scenarios. Not everything is solved, but yet the first expression is based on model elements, the doublon calls the first one: May be need to remove it and copy the exact condition. In that case I think the condition has to be described through class or enumerated values, and used by each copy.
The point is when transitioning an OAS, it seams that all OAS sharing material is affected, and is transitioned first, but the result is not correct, sometimes the concern is just on the diagram, sometimes on the scenario itself, and an OES exists already, linked to the appropriate OAS. The targeted OAS is not transitioned, first try, an empty scenario is created, with a warning, second try will give an error and hide the tree. Recovery requires closing the project and reopen.
I tried repair project: the routine works for a while and get stuck for more than half an hour sometimes at “saving items status”, requiring task killing by the task manager, whenever the repair task ends normally it reports “repair process could not be run”.
Then my last plan is to remove constraints sharing and even dependency, may be delete link to model and just write condition in plain text only. But, to me then, we are missing one of the mission of modeling: find and converge state transition conditions, use same conditions in scenario and converge scenario progress condition when applicable. Plain text seams to me acceptable for operational analysis during which we are looking to define the context, not after, because SA objective is to share a contract with stake holder about scenario execution, and precise interface to the actor the manage each.

Thanks for your help, If I get nothing with this plan I will (re)generated an obfuscated model.

Edit: Saving the session generates an error: To me it relates to folder path name length which is tough to windows. I use a long project name, but located as close as possible to C: root. Is there any chance to rename aird file and melodymodeller one?
Or to import all items in a new one?

Yes you can rename your project and your aird files. If I am not mistaken, you should start by renaming your project, then you can rename your aird file (it will automatically rename the afm file) and finally rename your melodymodeler file. Renaming is done by right clicking on the project or files, or using F2 I think.
All this should work pretty well if you’re using Capella 1.3.1 and onwards (

Thanks Stephane,
I duplicated my model to obfuscate… but then obfuscation did not complete!
So I restart from my last export before PC migration: at the moment I’m solving model validation issues… but some items are not found despite existing (eg message invoking interactions) I’ll try to replace them…
Some items are missing and dangling in expressions: for these one, I just cleaned, as I will have to duplicate constraints in order to avoid sharing them between scenarios. My plan to keep unicity of condition is to set up a variable (class or enumerated, to be decided) but then, the value will described in plain text. The last point is: Do I need another constraint for the OES, or can it be the one used by OAS?
I understood why the migration generated so many empty OEs: the metamodel change requires to decide for each OE Entity/Actor and Human/Non human, some issue generated non filled out duplicates. (I removed them)
The error log is complaining about home directory (not set up) for Java, I don’t know the impact of it for the model, so I’m now looking for what should be in eclipse.ini to solve. (Thanks if you can give some information there…)
Thanks for all

PS: current eclipse.ini


I do not beleive this is a big issue if your Home for java is not set, but could you copy the error you get?

Please find below an example of this recurring warning.
Notice at same time that eclipse has now missing build id… Did I something wrong?
Only change made is change xmx value to 4000m in eclipse.ini

I think I have my answer about transition not done: the issues comes from a common constraint between several scenarios. I would like to know this was ment in the tool or if it is a design constraint. The system and its context run scenarios in which same value assessment may condition several of them, while they may run in parallel. My work concerns vehicles and coolant overheat may lead to several behaviors… I believe that in precedent version it was possible to design like this. I change my model to avoid reuse of constraints between scenarios… The next question is if a constraint cannot be guard in several scenarios, can it be guard in state transition at the same time? The scenarios make the system run inside the state machine, so to me it’s important the same data controls both view. My point is that in my case several scenarios run the same state transition… I can set several triggers, but only one guard.

java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86_64

Fri Sep 18 14:04:43 CEST 2020
Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: ‘H:\’. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

Hi Tierry,

About the HOME variable, the warning your are getting is related to thg git integration plugin, so if you’re mot using git to store your model, I beleive you can ignore this warning.

About your other question, I am afraid I don’t know the answer, maybe somebody from the Capella team can help…

All the best,

Thanks Stephane
About Capella team, I understand you are answering more about Eclipse than specifically Capella. I hope they will read this thread, because to me, not using the same condition for the cases it shall apply is deviating from system designing, or at least creates a PLM issue within the model, as the same ment data is repeated several time. Thus we can experience an issue when change of this common condition is needed (remember that using same name or leaving unnamed items may lead to tree view readability, warning or error issue when too close in the tree, so each repetition has different name, the filter is less efficient). And having plain text instead of referenced names in the expression is again the same issue. This brings me to another one: in the new version 1.4.1, I had to forget edit/copy-paste and use windows clipboard… Capella team said an issue report was raised for this. But the search tool Ctrl F is unavailable as well! I’m not IT people, I would dislike when absolutely necessary look at my model through another workbench to use Control F!
Thanks again still
Thierry Poupon

I was answering specifically for Capella, but I am not part of the Team that develop Capella, so my answer was basically “on your second topic this goes beyond my current knowledge so I cannot answer it”.
I hope the Capella team can find some time to answer, but this is an open forum, there is no guarantee you’ll get an answer…

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.