Running Capella on Ubuntu 18.04

I have tried it on three different machines. It runs on one. It opens an empty window on another one and it returns an error message without opening a window on another machine. I was wondering if you have seen these issues.
This is the error message: Job found still running after platform shutdown. Jobs should be canceled by the plugin that scheduled them during shutdown: org.eclipse.egit.ui.Activator$1
Gtk-Message: 19:24:22.883: GtkDialog mapped without a transient parent. This is discouraged.
I get this error even if I restart the computer. I was wondering if someone could help me with this.

Hello,
There is an old post on this topic:
https://forum.mbse-capella.org/t/658/
Does it work for you ?
Hope it helps

Hi,
One of the most important things to check is that you have a Java 1.8 version (only) and 64bits as well; ideally this version:JRE 1.8.0_121_64b . You can get this version from here:
https://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html
Then you can also have a look at this thread:
https://forum.mbse-capella.org/t/640/
Stephane

Thank you Stephane and Navas! After three days of trying different things, I tried to run Capella on MacOS and that lead me to new problems that I was able to solve following
https://forum.mbse-capella.org/t/640/ and installing Java and then changing its version.
That gave me an idea that the problem might be the version of Java. Finally, I was able to run Capella on Ubuntu 18.04 by rolling back Java OpenJDK from 1.11 to 1.8 using this command:
I hope that Eclipse is now more stable compared to a few years back. I used to lose all my settings from time to time because of Eclipse crashing. That is why I left Eclipse and never used it until now.
Installation guide on Capella’s wiki is limited to Windows. I wish this information was available on the wiki for Ubuntu and MacOS.
Thank you again

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.