Requirements Viewpoint ReqIF import datatypes

I use ReqIF Stuio for requirements, Formalmind Studio, in other words.
I see that Capella imports the structure of the Specification, but the names that are used cannot be reproduced. Capella imports requirements with empty text.
How can I name my datatypes to be compatible with Capella?
Image and reqif attached
Thanks!
Mehmet Ali

Hello,
I have more or less the same issue as you.
While types were corrrectly imported, the requirements are partially empty. Only the “Req IF Identifier” was imported as expected.
Description, ID, or Long Name are all empty.
Mathias

Hello Mathias,
you can control by “Preferences -> Capella -> Requirements” which attributes are imported and the way the requirement is labeled.
cu

Hi Richard, I see that there is a list that we can select the attributes to import.
And there is ReqIf.Description there, but the Description attribute in my ReqIF is not imported.
So, I am wondering whether I should name it accordingly to match Capella. But I don’t know how.
The second one is about how it is labeled and I get that it checks for possible candidate attributes for that.
It probably can’t find anything, therefore the label is empty.

All right, I should have read the help file.
One can set which attributes will be imported through a properties file defined on the Preferences dialog>> Capella>> Requirements>> Importer.
Be careful with the whitespace in that file. Don’t copy paste.
Then, one can change the aql query on the label expression form element.
In order to print the correct labels on the diagrams, one should edit by right clicking the root “System Engineering” of a Capella project. It is the first item as ProjectName under your ProjectName.aird item.
One can write aql queries there also.

My other question would be this. I imported my requirements successfully.
Editing requirement’s content and label works differently for me.
I tried writing down the same query for both:
“aql:self.ownedAttributes->select( a | a.definition.ReqIFLongName == ‘ID’).value”
such that it will show ID on both north and south of the box.
I end up with the north side populated with the ID, say “REQ 23”
But the south side is empty, it seems to me that Requirement’s content is not parsed correctly.I end up with:
±-----------+
| REQ 23 |
±-----------+
| |
| |
| |
| |
±-----------+

Quick workaround, I print all the data in the label of the diagram with the query:

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.