Requirements plugin not working on made projects

Hello,
I am not sure if this is a glitch or not but I cannot access the requirements plugin on a project that was created before I installed it. If I create a new capella project everything works great, but I cannot turn on the layer view or access the sidebar shortcuts on a project that I already worked on.
Is this intentional? Is there any way to fix this? I would like to not restart my whole project in order to use requirements. I have tried copying a previous project but come across the same problem.
I am using:
Capella 1.3.0, Requirements 0.10.0, Java 1.8
Thank you,
Daniil

Hi,
Did you reference the viewpoint to your project as described in the documentation (attached screenshot)?

Hello,
Could you attach your model (offuscated if needed) so that we can have a look. For now I see no reason why it works on new projects but not old ones.
Regards,

Hi,
even if you enable the diagram layer through upper Diagram toolbar (see attachment)?
Best regards,
Michel

Hi Michel BISPO,
Yes, clicking the layer button does not show any activation.
I tried to reinstall the requirements tool. Below is the message I am getting.
Cannot complete the install because one or more required items could not be found.
Software being installed: Capella Requirements VP CDO Feature 0.10.0.201901071243 (org.polarsys.capella.vp.requirements.cdo.feature.feature.gr oup 0.10.0.201901071243)
Missing requirement: CapellaRequirements CDO Model 0.10.0.201901071243 (org.polarsys.capella.vp.requirements.model.cdo 0.10.0.201901071243) requires ‘bundle org.eclipse.emf.cdo 0.0.0’ but it could not be found
Cannot satisfy dependency:
From: Capella Requirements VP CDO Feature 0.10.0.201901071243 (org.polarsys.capella.vp.requirements.cdo.feature.feature.gr oup 0.10.0.201901071243)
To: org.polarsys.capella.vp.requirements.model.cdo [0.10.0.201901071243]
Thanks in advance.

Do you try to unzip the requirement dropin inside capella dropins folder? Pay attention to unzip first capella in a folder which a short installation path, and switch to a new workspace (adding a “-clean” in case of installation issue).
Have a look to installation procedure of Capella and dropins, see embedded Capella Help,
https://polarsys.org/forums/index.php/mv/msg/679/2722/#msg_2 722

Hello all,
If you do a right click on the aird file, and goes to viewpoint selection, can you check that “CapellaRequirements” is selected?
(see enclosed capture)

Hello Seon,
The error you saw when installing the Capella Requirements VP CDO Feature is normal. This feature is packaged to work with a collaborative environment for Capella. In a normal Capella, this feature is not activated at all.
Btw, I’ve also tested your usecase with a migrated model from Capella 1.2.x/Requirement viewpoint 0.9.1 but the layer was activated just fine.

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.