PVMT silly question


Relatively new user here. I’m running Capella 6.1, PVMT 60.7.0, and DS 60.3.1.

I’m having trouble getting the Property Values tab to pop up next to the Semantic Browser. The youtube tutorial I’m using is using Capella 1.something. Is there another way of actually assigning the property values to components and component exchanges?


If you lost the view, you can show it by going to the menu Wondow->Show View->Others and then look for the “Property values” view under “Property values”.

I’ve done that. It pops up a separate window with a blank Property Values table. Is there a way to reattach it?


If you have properly defined your property values definitions on the component and component exchanges you want, then when you select a component, this view should display the properties that you can assign to the component/component exchange.

Hi @StephaneLacrampe .

I have a follow-up question (silly?) to this that I’m hoping you can help with:

Every time I close and re-open Capella, the Configuration PV is blank and I lose all the domains populated in the Configuration PV, and consequently the ability to change properties from the Property Values window (when an element with a property is selected). The one workaround is to export the domains to a safe location and re-import them every time Capella starts up, however, this can become very cumbersome when you start to have a large selection of domains.

What can I do to prevent this? Is there a setting I am perhaps missing?

Estian Malan

Well, I don’t know why you’re experiencing this behaviour but this is completely abnormal. Your configuration PV should be saved and kept when you close and reopen Capella.

Hi @StephaneLacrampe. Thank you for the quick response.

Could we perhaps run this by the developers to see if they received any similar reports? Perhaps they could run an experiment to verify on their side? Maybe there is some installation glitch with PVMT that crept into my system. I will experiment with a fresh copy of Capella and PVMT to compare.


A quick update: Looks like the problem magically went away. Not sure how or why… Strange behaviour indeed…