Proxy Settings

Hi,
I would like to set some proxy settings in my Capella Studio plugin project, so I set Host, Port etc…in the Preference menu in the network connection tab. I also set http & https Host & Port in the eclipse.ini file but when I launch the code in Capella Studio I have error message that tells that “System property http.proxyHost is not set”. I don’t understand why I have this error message because I already set the proxy like I write it before.
Did someone has a clue ?

Hello,
This stackoverflow post sums up the different solutions to your problem. Usually, adding these settings in eclipse.ini file is the way to go. Try something like below and clear socks settings in Preferences.

Thank for your response, I tried to fix it with your solution and the stackoverflow solution but it did not work. I don’t understand why it does not work. I have the feeling that the modification that I made in the ini file is not take into account.

You can also add an argument to specify custom java binary like below. That way you’ll get a java console that might help you debugging the situation.

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.