"Properties are not available" + Uninstalling addon

Hello! I have an issue with Capella.

I have installed a version of the requirements viewpoint (0.13.1) addon which is not supposed to be compatible with my Capella version (5.2.0).
Probably related to this, I now have no access to the properties of my elements. The properties tab shows “Properties are not available”.

In the information tab it states: "ExtensionPointHelper.createsInstance(…) _ Unable to instantiate class type:org.polarsys.capella.vp.requirements.Requirements.provider.CapellaRequirementsItemProviderDecoratorAdapterFactory | Error | | null | "

So I would like to uninstall this addon and install an appropriate version of it, such as Requirements Viewpoint 0.12.2
So I go to Help > About Capella > installation Details. At this point I see the Capella Requirements addon files but the button to uninstall is not active.

Do you have any advice on how to proceed? I have a model with information I would like to keep.

You could try to revert the configuration by looking at installation history. There you can select last working configuration by date.

Thanks for the suggestion. I didn’t know I could do such a reverse.

I reverted it, but it did not solve my issue. I had created a requirement just to play with the tool - but it seems to me that either:

  • I activated something in the software or
  • I have some element which I should delete - I looked for such element where requirements would fit but did not find anything. (Is this even a good guess?)

After reverting to a version without the requirements, I got a message with “Problem occurred”:
Missing viewpoint ‘org.polarsys.kitalpha.vp.requirements’
org.polarsys.capella.common.platform.sirius.ted.MetadataException: Missing viewpoint ‘org.polarsys.kitalpha.vp.requirements’
Content access has failed at editor opening, you can try to reopen this editor.

I also tried to install the compatible viewpoint but again, a “Problem occurred”:
Expecting version ‘0.13.1’ for viewpoint ‘org.polarsys.kitalpha.vp.requirements’ (current version: ‘0.12.3’)
org.polarsys.capella.common.platform.sirius.ted.MetadataException: Expecting version ‘0.13.1’ for viewpoint ‘org.polarsys.kitalpha.vp.requirements’ (current version: ‘0.12.3’)

I have installed Capella version 6.1.0 with the viewpoint 0.13.1. then I migrated to project to version 6.1.0 and it seems to have solved the issue of the Properties. They are working correctly now.

While Properties issue was solved, I now have another problem to solve related to version 6.1.0 which can be read in the link below.