Project won't open anymore after reload

Capella 1.4.2., I was working in my project. I tried to change the theme to a new color. The tool asked with a pop-up to restart. I accepted and it reloaded automatically.

After the tool came back, I receive a very nasty error…
Missing viewpoint ‘null’
org.polarsys.capella.common.platform.sirius.ted.MetadataException: Missing viewpoint ‘null’

First, the diagrams won’t open. I closed the project, and now the aird does not open.
I tried with a new fresh Capella (I deleted the directories of the app and upzip the program again), same issue. Other projects work but mine.

I dont have a backup of the project. I also dont have experience troubleshooting any issue with Capella.

Could you please help? :frowning:
Any clue how to troubleshoot this?

Hi all,

I solved the issue. I believe the problem was a mismatch between the .afm and the rest of the files.
I opened the afm in notepad++ and removed a line that made reference to metadata. After this line was removed, the project seems functional again!

Before

<?xml version="1.0" encoding="UTF-8"?>
<metadata:Metadata xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns:metadata="http://www.polarsys.org/kitalpha/ad/metadata/1.0.0" id="_1XZrgGM_Eey6j4NT_0pt4Q">
  <viewpointReferences href="#_1YDy0GM_Eey6j4NT_0pt4Q"/>
</metadata:Metadata>

After (line 3 was removed)

<?xml version="1.0" encoding="UTF-8"?>
<metadata:Metadata xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns:metadata="http://www.polarsys.org/kitalpha/ad/metadata/1.0.0" id="_1XZrgGM_Eey6j4NT_0pt4Q">
</metadata:Metadata>

I am very happy this was the issue. We tried hacking the aird but we did not manage to solve it there :slight_smile:.

I am not sure about the root cause of the problem. I was working on my one-drive directory. But I think the issue was with the ‘reload’ action of Capella after importing a color theme.

Anyhow, thanks in any case!

(previous post should be the solution…I dont know how to indicate this)