Problem migrating from Capella 1.4.0 to 5.2

Hi,

I’m trying to migrate an existing Capella project from 1.4.0 to 5.2. I can import the existing project in Capella 5.2. However, when I right-click on the project (in order to select the migrate option), I only get a “New” option on the menu. Any idea?

Cheers,

Oriol

To do the migration, you probably need to migrate it to 1.4.1 and 1.4.2 first, and then maybe to 5.0 and 5.1 - not sure though.
Stephane

Thanks for the information. Does anybody knows for sure? I’ll need quite some time to install each of these versions and the plugins associated to them.

You shall be able to migrate from 1.4.0 to 5.2 without migration with intermediate releases.
Are you still blocked?
The migration menu shall appear when you right click on the root project

Hi! Thanks for your answer.

I think the problem was with the filtering plugin, which maybe is not compatible with Capella v5.2. When I remove the plugin from the capella plugin folder, everything seems to work fine. If the plugin is there, the contextual menu on a project only contains the option “New”.

So now I think I must detach the model from the plugin in version 1.4.0 and then perform the migration.

Best regards,

Oriol

Hi,

With the switch to Capella 5.2, just make sure to update also the filtering addon to a newer version,
Filtering v1.5.2 as Filtering addon used for 1.4 is not directly compatible with Capella 5.2.

Philippe

Thanks! I was using the old version by mistake. Now everything seems to work properly.