M2Doc template and diagrams image generation (various issues)

Hello,
I have also issues to use the M2DOC feature with my Capella workbench (1.3.0 and M2DOC 2.0.2). Sorry if these issues have been already solved in other posts.
1.First of all, I do not have the same window than those presented in other posts where the M2DOC menus are integrated in Capella window. They are more pop-up windows (see attached image) and it seems that i don’t have for exemple the “initialize option” available. Is there any additional step before using the M2DOC feature?
2.I tried to use the IFE M2DOC exemple to generate documentation for my Capella project. For the IFE, I succeed to re-generate the IFE documentation by using the existing genfile. Then when I use the IFE template for my project, the new associated genfile works fine for the variables like “self.name” ; “self.containedSystemAnalysis.ownedActorPkg.ownedActors” but not for image generation.
Errors are for example:
{m:for im | self.containedSystemAnalysis.ownedSystem.asImageByRepresenta tionDescriptionName(‘System Architecture Blank’)
Invalid for statement: Couldn’t find the ‘asImageByRepresentationDescriptionName(EClassifier=System,j ava.lang.String)’ serviceInvalid for statement: The iteration variable types must be collections ([Nothing(Couldn’t find the ‘asImageByRepresentationDescriptionName(EClassifier=System,j ava.lang.String)’ service)]).
3. Investigating on that issue, and comparing both Genfile (IFE and mine), it seems that the values for the variable are the melodymodeller file + capella sources (ecore) for the IFE one (see attached image) and only the melodymodeller file for mine. How can I associate these values to the variable self (I don’t see how to load this type of source)? Is it linked to my issues with the image generation?
Thank you in advance for your support on that.
Best regards,
Romain

  1. The initialization is done automatically when creating the .genconf file. Also options can be changed in the next step of the wizard you shown in pop-up.png, you need to select the “options (expert)” tab on the top left of the wizard. You can fine more details
    here.
    2. The image generation problem from your .genconf file means you don’t have a proper value for the option “SiriusSession” it should reference the .aird file of the IFE project. The URI can be absolute (not recommended for portability) or relative to the .genconf file:
    /project1/representations.aird
    /project2/templates/my.genconf
    In this case SiriusSession should be set to “…/…/project1/representations.aird”
    3. Once the SiriusSession setted properly, All semantic resources from the session should be available to bind values for model variables. By default the first semantic element matching the type of the variable defined in the template will be selected. You can change that in the variable tab on the second page of the genconf wizard.

Thank you!
It works fine by using the relative path to the aird file.
Regards,

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.