M2DOC migration 3.1.1 to 3.2.1

I just updated from Capella 5.0 to 5.2. That why I also had to update from M2DOC 3.1.1 to 3.2.1. The migration in capella worked w/o any problems. But when I try to generate a doc with an old template I receive many errors that several classes can_t be loaded.
I guess I figured out that several references to URI and/or import of services changed.
Is there any overview with which references I have to switch or exchange to migrate my old templates to the new M2DOC version?

Thanks in advance and best regards

I think it should not be the case, the only change needed is the M2Doc version number in the template. Capella metamodels’s nsURI did not change between 5.0 and 5.2. I also hope there was no API breaks between the two versions…

Do you have the error message that could help finding the missing service or nsURI ?

Hello Yvan,
It seems to be all services of the bundle org.obeonetwork.capella.m2doc.aql.queries.
It starts with this: "can’t load service class
I wonder if there something went wrong during the installation of m2doc?
Best regrards Carsten

Have you tried to right click on the template (within capella view) and check its configuration?
imageCapella, might have been unchecked.
Check also your genconf config+,

Hmm yes, you are right, Capella is not checked at the Packages tab.
But it is not simply unchecked, there is no package to check…The complete tab is empty and so I can not check or add here anything. When I compare it with my old installation (Capella 5.0), there is the “Capella” package to check/uncheck.

Never seen that, i will let more knowledgeable people respond,
Try to use screenshots in your comments, it could help solving your issue faster.

I think something went wrong with your installation. You can check the list of installed software: Help / Install new software then use the already installed software link at the bottom.

After trying to compare configuration I finally uninstalled and began with a fresh capella 5.2 installation.
Because of some restrictions I could not use the update over the internet, so I downloaded the ZIP. At my attempt yesterday I opened the “install new software” and located the ZIP by using the “add” button.
Each time I received an error but M2DOC was listed.

Today I tried a different way for the M2DOC plugin, and now it works. I opened the “Manage” menu and added the ZIP file to the list of Available Software Sites.
After Apply and Close the ZIP could be selected at the pull-down for the “Work with” option.
This time the M2DOC was installed without any error message.

After migration of my model and importing the templates I now can check the “capella” package at the template configurations. This time the document generation was successful :slight_smile:

Thanks for your answers and help
Best regards

1 Like

As you can see @YvanLussaud , this is not a rare occurrence, if this person wanted to use P4C, he would not be able to upgrade “pip” easily.

P4C tech is incredible and was probably difficult to implement, So I am probably asking too much, but IMO there should be some version where no pip upgrade is mandatory (and no env VARIABLES (PATH) is mandatory). Maybe in the future, if it’s not the case already in the latest versions

As you know I had found a workaround for the problem, but when I tried to use the tech inside an even more restricted environment, I could not make it work.

I totally understand but the pip issue is related to the Python and pip packaging. Maybe we can do better…

1 Like