M2Doc 2.0.0 - error extracting diagrams

Hello!

I’m writing a M2Doc template in Capella 1.2.2 using M2Doc 2.0.0. I have encountered an error to extract diagrams which I’m not able to solve. I have tried also to use the example template from IFE model to test if the problem was in my template configuration, but I get the same error and cannot extract any diagrams.

I attach a screenshot of the code with the error I get in the template validation.

Here is the template configuration. I have added all the *capella and *sirius services.

And when Initialazing Document Configuration, I have also set the variable and the SiriusSession.

I don’t know what else to check, could you help me to solve the error?

Belén

If the SiriusSession reference the .aird file, you should be able to call the service… Do you have an error in the error log view after running your generation ?
You can also try to call the trace() service to see if the service appears in the output. If none of the Sirius services appear, you probably need to double check your SiriusSession option. The path for this option should be relative to the .genconf file.

Thanks for your answer Yvan. The path for the SiriusSession was not relative to the .genconf file, thanks for that tip. I have corrected that and now I don’t obtain a validation file when generating the documentation. However when I try to open the generated file I get this errors in Capella. Any idea of what is going on?
image
image
image
image
image

I can’t read your screenshots, can you past the test of the stack trace here please ?

I used the trace() service in the template but didn’t get anything in the output.

Regarding the screenshots I attached in the previous message, I keep having them when I open the generated file with the In-Place Editor. However, if I open it with the System Editor, I get this warning from Word:
image
But if I click ok I can see the generated file (including diagrams :slight_smile: ), in Word.

So, the generation works, but there is something why I cannot open the file with the In-Place editor in Capella.

The last problem you get is most likely fixed in the current version of M2Doc. And I recommend always opening your docx files with the system editor (aka MS Word). I noticed some strange behavior when using the editor inside of Eclipse.

1 Like
Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.