Interactions do not show

I am new to Capella. I am teaching Model Based Engineering and wanted to offer up Capella to the students as an option.

I am following the toy tutorial. When I get to the operational activity section and try to create an interaction for “Toy moved to play area” nothing shows up. I tried several tests, and no interactions show up on the diagram.

Hello Mike,

Thank you for your question.
If I understand well, you are trying to create Interactions from an OES diagram. Does the dialog box to name the Interaction show up or does nothing happen at all?

Martin Le Bourgeois
ObeoSoft Canada

The dialog box shows up, I can name the interaction, choose the source and target, but when I click OK, nothing is displayed.

Tried it on my end and it works for me - very strange it is not working on your end. What version of Capella are you using? What Operating System?
Stephane

Also, can you open the view error log and tell us if you’ve got any error in there?
(windows->show view->others->error log

I have Capella version 5.2.0 Build 202111301257
I am running Windows 11

Error log is too big to copy here and I do not have the rights to upload the file.

There are a number of errors “Error while modyfying model : org.eclips.sirius”

Hum, this is very strange - difficult to see exactly what is going on without the error log - at this stage, I may suggest redoing the Capella installation (unzipping the zip file) or maybe before that, create a new Capella project and restart the tutorial from scratch - I don’t see why you’re having this issue, sorry.

Ok Thanks I will try both.

Just wanted to say, I had this exact same issue with same error code with the same tutorial. Capella 5.2.0. build 202111301257 Simply restarting the program fixed it.