Installation procedure for Capella 1.1.0 on Mac OS

Hi,
I followed the procedure to install Capella 1.1.2 on my Mac and ended up with this error: “The Eclipse executable launcher was unable to locate its companion shared library”
Any help will be very much appreciated.
Thanks, Wael

Please have a look to this “sticky” thread:
https://forum.mbse-capella.org/t/382/
Note that Capella 1.2 (due in December even though development versions can already be downloaded) will work natively on Mac OS; without any dirty trick.

Is it possible to get a link to download the beta version of Capella 1.2 for macosx?
Thanks, Wael

I got this link to download a beta version for Capella 1.2 on Mac that is supposed to be ready for use without any tricks.
https://hudson.polarsys.org/capella/job/capella-master/941/a rtifact/releng/plugins/org.polarsys.capella.rcp.product/targ et/products/

That should do the job. This is not the very latest build, but it should be alright. Keep us posted!

Hello,
trying to install capella on my Mac Mini with Yosemite, I followed the link to hudson… and took the latest stable relase:
https://hudson.polarsys.org/capella/job/capella-master/1006/ artifact/releng/plugins/org.polarsys.capella.rcp.product/tar get/products/
But no luck. Upon starting Eclipse I get the message “The application “Eclipse.app” can’t be opended”.
It seems the mac is running Java 8. Did I miss something? It was said this release works “out of the box”.
Thanks
Martin

It was supposed to… The development version I tested a few months ago worked out of the box.
However, this time the fix is pretty simple:

  1. explore the content of the APP package and locate the Eclipse file in MacOS
  2. open the console and make this file executable (chmod +x)
    Do you need a more detailed instruction?

Thanks Stephane,
now I’m getting further, until I’m insulted with the message
“Versin 1.6.0_65 of the JVM is not suitable for this product” and
“Version 1.8 or greater is required”.
Checking Java in System Preferences tells me I’m using Java 8, “Platform” 1.8 and “Product” 1.8.0_151 (see picture), and an automatic update has been done very recently. But thats JRE not JVM… the latter I cannot find.
Is OSX Yosemite 10.10.5 already too outdated for Capella?
regards
Martin

Finally I got Capella running. Problem was, although the right Java version was installed on the Mac, the path seems to point to the wrong version as it is not correctly updated when automatic Java updates take place.
See this thread that pointed me to the right direction:
https://stackoverflow.com/questions/35246910/eclipse-not-rec ognizing-jvm-1-8
I installed the current JDK and then Capella started up fine.
regards
Martin

I am trying to install Capella on my Mac (OS 10.13.6). When download the file from website I only get the attached files. Double clicking on Eclipse says “application can’t be opened.” Surely someone has come up with simple install instructions for a Mac?? I saw a webinar on youtube where the demonstrator was using a Mac so it must be possible. Thanks for any help!

I git the same message on High Sierra. It was an easy fix:

  • Open Terminal
  • Navigate into the app (Eclipse.app is a folder): Eclipse.app/Contents/MacOS
  • run: chmod 775 eclipse
    For some reason there were no execution rights given to anyone.
    Enjoy!

I appreciate your help, but I STILL could not get this to run. Attached is the contents of the folder I have. I opened Terminal and did a cd to get to the folder, then I typed: run: chmod 775 eclipse as you suggested and I got the attached.
I would greatly appreciate someone putting together detailed step by step instructions for Mac users (who are not familiar terminal commands). Thanks!
p.s. I have java version 1.8.0_152

Hello Jerry,
Try without 'run: '. Simply ‘chmod 775 eclipse’ should do the trick.

I get “No such file exists”. See attached.

Hello Jerry,
It seems you downloaded the Windows (.exe) rather than the Mac version? Or did you rename it?
In any case, the last screenshot shows you at the underlined level in the folder structure:
Eclipse.app/Contents/MacOS
However, you need to go all the way down to ‘MacOs’.
Here a few handy Unix/Linux file handling commands:

  • ‘ls’ … list directory (to see the contents)
  • ‘pwd’ … print the current path
    Hope this helps

Hi,
Once you have downloaded the correct version (i.e. not the windows executable), the idea is to open the application package (right click on Show Package Content should give you the same thing as I had in my message of Wed, 13 December 2017 16:55 (see above).
Then, you need to
open the terminal
change the directory to the directory shown on my illustration: “cd Eclipse.app/Contents/MacOS”
Once you are in the directory, type “chmod +x eclipse”

I appreciate everyone’s help but I’m still not getting this to work.

  1. I re-downlaoded the Mac Cocoa package from
    https://www.polarsys.org/capella/download.html (see attached)
    2.The contents of the package are different than when I downloaded before (see attached)
  2. I then tried both suggestions (“chmod +x eclipse” and “chmod 775 eclipse”)
    still no joy.
    Other suggestions (thanks in advance!)

Hello Jerry,
Might be because I am on the phone, but I don’t see attachments.
What is the message? At which step do you get stuck now?
Note that all this should happen in the terminal. Please post a picture showing all the steps you are taking.

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.