installation problem

I am new to Capella, want to try out the tool for MBSE study.
The tool started but stopped right after the splash screen, as reported in detail below. Any help is appreciated!
(1) Installed jre-8u202-windows-x64.exe on my ThinkPad, running Win10 64-bit.
(2) Created a folder C:\capella140, and installed Capella 1.4.0 for Win 64
in the folder.
(3) In C:\capella140\capella\eclipse, i have double-clicked “eclipse.exe”
(4) Splash screen appeared, and disappeared.
(5) The welcome screen didn’t appear, but instead, a small error window appeared
saying “an error occurd. See the log file”.
(6) In the log file, a Java runtime Exception is reported saying, “org.polarsys.capella.core.platform.sirius.ui.perspective.id” could not be found in the registry.,
where the top of the stacktrace is at “org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:252)”.
note1: the logfile, eclipse.ini etc are attached in the zip file.
note2: Tried jre-8u121-windows-x64.exe also, resulted same problem.
note3: In my pc, I have other JREs and eclipse installation, in 32-bit configuration. So I added -vm option in eclipse.ini to specify the 64-bit JRE explicitly.

capella140_cannotrun.zip
capella140_cannotrun.zip

Hi There,
I think the problem comes from your eclipse.ini file.
You should move the 2 lines before the -vmargs line:
-vm
C:\progra~1\java\jre1.8.0_202\bin\java.exe
Everything after -vmargs are arguments passed to the vm, so the -vm option must be set up before.
I hope this solves your issue.
Stephane
Obeo Canada

Thank you for your help, Stephane,
I corrected the point but the same problem persists.
My new eclipse.ini and the log file attached.
I attached also the config.ini file (in C:\capella140\eclipse\configuration)
this time because I found that it contains the following line, that matches the name mentioned in the log file.
eclipse.application=org.polarsys.capella.core.platform.sirius.ui.perspective.id
– hirosan

capella140_cannotrun2.zip
config.ini
capella140_cannotrun2.zip
config.ini

Hi Hiroshi,
I am sorry this does not solve your issue. The issue is definitely linked to a problem with the way Java is configured on your machine. I was not able to reproduce your issue, sorry, maybe you can try to re-install Capella and re-install your Java 1.8 version, I guess you already tried this. Maybe also have a look at your environment variables (JAVA_HOME, JRE_HOME, PATH).
All the best,
Stephane

Thank you Stephane,
I re-installed Capella and it worked fine this time!
The difference I can remind of is that this time I “moved” the directory “capella” to “C:”,
after unzipped the download package in Downloads directory,
whereas in previous trials I moved “eclipse” directory to the hand made directory “C:\capella140”.
Not sure if the above is the real cause, maybe I did something else.
Before the re-installation, I tried things related to environment variables (JAVA_HOME, JRE_HOME, PATH, CLASSPATH).
They didn’t worked, but one thing to be noted is that setting CLASSPATH changed the name of the
“not found” item in the log file report, so the direct cause could be related to classpath.
Now my problem is solved, and Id like to leave the investigation off here.
Sorry about the incomplete report, and thank you for your support!
– hiroshi

Well thank you very much for all these details, I am happy that it finally worked for you!
Stephane

Hi Hiroshi,
unfortunately I have the same issue like you. I already copied the unzipped capella folder to C:… and changed the .ini file. Each time after starting capella I can chose the project location but after that step the log file error message appears.
I´m using capella 1.4 64 bit with Java JDK 14.0.1.
I´m not familiar with Java coding. Could you tell me what I have to do with the environment variables? Attached you find my ini and log file.
Thanks and best regards,
Marius

eclipse.ini
.log
eclipse.ini
.log

Hi Marius,
Capella requires Java 1.8 64 bits, and ideally this version: JRE 1.8.0_121_64b, and you are using Java 14, hence the issues you’re experiencing.
You’ll find the right JRE for you at this address:
https://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html
Once installed, please revert the change you made to your eclipse.ini file, or unzip the Capella zip file to get a fresh start.
More information on installing Capella here:
https://wiki.eclipse.org/Capella/Installation_Guide#Capella_Installation
Stephane Lacrampe
Obeo Canada

Hi Stephane,
what a stupid mistake from my side :frowning:
Thank you very much for your help! Now it works and I can try my first MBSE Project! :slight_smile:
Regards,
Marius

My pleasure, I am happy I was able to help!
Stephane

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.