Importing requirements issue

Hi,
I can use some help understanding why I am unable to properly import reqif files (created with ReqIF Studio).
Two examples are attached here (reqif + rmf files).
The first - spec.reqif - has five requirements (in two hierarchies). It was done with basic attributes.
The second - spec1.reqif - has two requirements, done with additional ReqIF10 attributes.
The Requirements Addon is able to import the spec.reqif requirements, but does not recognize the actual content of the requirements. (In the expert properties of the respective modeling element in Capella I can see that the “Requirement Type Proxy” has the original identifier of the spec object in ReqIF studio, if this helps).
As for the second file - spec1.reqif - the Requirements Addon is not able to import it. After selecting the file for import I get a message stating two problems occurred:
Load ReqIF resource (An internal error occurred during: “Load ReqIF resource”.
java.lang.String cannot be cast to java.math.BigInteger)
&
Merge of ReqIF elements (An internal error has occurred. java.lang.NullPointerException)
Any advice? Thank in advance for trying…
Avi

Spec.reqif
Spec1.reqif
Spec.rmf
Spec1.rmf
Spec.reqif
Spec1.reqif
Spec.rmf
Spec1.rmf

Hello,
There is a post in the old forum about ReqIf import:
https://forum.mbse-capella.org/t/782/. You will find there a sample file that you may want to compare with yours and check the differences.
The ReqIF importer works well with DOORS-generated files, but I’m not able to say if it will work with ReqIF Studio.
Hope it helps.

Thank you.
I suspected that there is some DOORS-specific implementation.
The main point of ReqIF is to allow compatibility between tools.
I wonder if anyone else can report using a non-DOORS ReqIF file with the Capella Requirements Addon. I tried to find another open-source implementation but could not find one. Does anyone use Codebeamer and can try the Requirements Addon with a Codebeamer reqif file?
Thanks!

The ReqIF importer has been already used with ReqIF files exported from other requirements management tools.
In some cases, these tools generates ReqIF files with specific features. So the issue may not come from a Doors-specific implementation of the ReqIF importer, but may also come from a ReqIF Studio specific of the ReqIF exporter :wink:
I suggest you to compare your file to the file in the old forum post I mentioned in the previous post. You may find some differences that could be the cause of your issue.

I had every intention of following your tip Navas, Thank you!

I think I am running into a similar issue as the OP except my primary issue, getting the following error:
“An internal error occurred during: “Load ReqIF resource”.
org.eclipse.rmf.reqif10.impl.AttributeDefinitionBooleanImpl cannot be cast to org.eclipse.rmf.reqif10.AttributeDefinitionString”
If I check the “Force DOORS RMF usage check while importing requirements” preference, I end up with no imported requirements at all.
I am generating my ReqIF from DOORS NG, with artifacts in Modules similar to the linked thread… I wonder if the custom artifact functionality in DOORS NG/ReqIF Studio (at least that are different from Rationale DOORS) are the source of this problem…

Solved my problem above through some painstaking isolation.
I was having mixed results as I attempted to import different sets of requirements (segment sections of the whole). What it came down to is this:
In DOORS NG I have a field listed as a boolean (TRUE/FALSE) to denote specific applicability. Isolating down to importing a single requirement that worked versus a single requirement that did not work and then inspecting the fields of the ReqIF, it looks like if that field was not filled in in DOORS NG it defaults to “false” (string). The problem is, further up in the ReqIF, it defines that field as being a Boolean.
Adjusted the field appropriately in DOORS and that particular issue above is solved.
QED
:slight_smile:

Thanks for sharing your solution!

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.