How to transform Capella Sample Add-ons into "Effective working Workspaces" in Capella Studio? Without losing any link/info

Capella Website offers the following free SAMPLE addons:

These addons are designed to help start developping on Capella Studio.

(Add-ons that show how to start developing add-ons for Capella using Capella Studio)

So I downloaded the first addon (Basic Mass), unzipped all the .jar files into one folder and opened it with Capella Studio.

One problem encountered would be “not being able to open the Service classes” on Capella Studio, under .Odesign.
I figured it might because of the name of workspace that has been changed, originally(workspace where the addon has been developed first) VS the new workspace (mine).
I provided the error message associated to the issue, here it is:

I tried to make a new extension and open it, it has the same error pop up message, So i figured the problem might lay elsewhere.

Other could not be opened, aswell as the mass.GENMODEL.

What is the best way to open a Sample Add-on in Capella Studio? Was my method consisting on collecting all extacted .jar files good enough?



It seems strange that the imported projects names are the original plugins names with the version added. Would it be possible that it is the cause for the problem ? Maybe you already have the plugins already installed in your Capella Studio install.


Hello Arnaud,
I don’t have these types of error messages anymore.
I had them, before you explained to me how to import properly an addon in the message of last week. Thanks again by the way, i reacted to your response.

It comes to 2 problems as far as I gathered:

  1. The right way to import these, is to use the plugin view, AND have the files inside the dropings folder in order for them to appear in the list, or In case you have an open/admin network, then just use the update site, in my case using the update site never works as I have a protected network that would block it.
  2. If you are not importing the right way (using the file → import), then if CS is not open in admin, the “.sources” will not be imported and an error message will appear, causing afterwards to have all type of erros for your class or java files, as seen in the first post. A method to avoid these errros would be to use desktop space (in some instances Desktop gave me admin privilege (limited to this space) althought i was not).

I got rid of all of these errors messages thanks.
I will try again, in few days when I have time to use the plugin view method to import an addon, in a protected network to see how that goes.


Ok thanks for the feedback.


Hello @ArnaudDieumegard ,

  1. I tested it inside a protected Network, the import process (method 2) did not show any error seen previousely.
  2. However, I have noticed another problem:

On the left the original project, on the right the result of the import.
→ Was this caused because of errors popping up on .odesign and .af? Does this happen anytime any tiny error appear = no migration of the folder?
Error was related to a path, I corrected that, some warnings were presents in the manifest, i used the automatic correction though.
I would have prefered if the behavior or “plug-in viewpoint” was to import everything (with the errors), especially when the errors come from older configurations, but maybe it is best like that.

Here is what looks like the error logs for capella studio “target” =>

I don’t know if that could have been useful to us, and informed us that the errors were related to paths?

The update site I used to get the plugin before importing it, DOES contain all the parts, look:

We can see clearly (.af) and (.odesign) plugins…
Got My answer:

So these plugins even if they are appear in the update site they will not be installed because of the errors.

1 Like