Error 'Failed to Create the Part's control'

Hello everyone,

I just experienced a strange behavior with M2Doc (v3, on Capella 1.4.0).

After a template generation, it was impossible to open it from eclipse (see picture),

The file opens when you use Word though.
So I have done a little bit of searching, and identified what part of my template was responsible.

I found that to delete this piece of code remove the problem:

So I tried to create a new template with only this piece of code in order to make a little more investigations… However, the generation worked fine for this new template !

Any idea of what can be this behavior ?

Rgds

You have this error when opening the word document inside Eclipse ? It’s probably related to the integration of MS Word with Eclipse… not sure how to improve that.
Some time this can happen when the document is already opened in MS Word outside Eclipse or by some other process. I don’t think this is related to the document itself.

Yes, it was while opening the document in Capella.
If I then try to use Word, the following error appears:

image

And then

.

By clicking yes, my document is generated. So it is not prevent me to do anything, even if there is that strage error.

Hi,

Something in the footer is generating an invalid document. Default header and footers presentations from MS Word are known to produce his kind of error with M2Doc.

Thank you very much Yvan !

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.