Cross-Level Analysis Plug In

Hi All,

Has anyone successfully used the cross level analysis plugin?

I have downloaded the version for 1.4.2 and put these files in the dropins folder of my capella installation.

I have tried putting this in:

  • “eclipse” folder (Capella 1.4.2>eclipse>dropins>cross-level-analysis_1.1.0>eclipse> features & plugins)
  • Going straight to the “features” & “plugins” folders (Capella 1.4.2>eclipse>dropins>cross-level-analysis_1.1.0> features & plugins)

But this is not showing up the viewpoint manager.

Thanks for any advice you can offer.


Hello Josh

Reading from the “Usage” documentation

Select an object, right click and select “Cross Analysis” → Init Cross Layers Diagramme (CLD)

It seems like there is no way to activate/deactivate the viewpoint from the Viewpoint Manager

I was able to install it and use it on a 1.4.2 to generate a “Cross Layers Diagram”
Right click a Logical Function made the menu “Cross Analysis” appear

In order to make it work, I placed the content of the zip (plugins and features folders) inside Capella1.4.2/dropins/CrossAnalysis/



Thanks for the response @ErwannTraisnel.

I have unzipped the folder straight into dropins folder.

I can now see the Cross Analysis Menu when right clicking on an object. When I select the Init Cross Layers Diagram I get the following error:

“No Cross Analysis viewpoint found. Please activate the viewpoint”.

On the webpage it does say the following:

Download the build and unzip it in the dropins directory within your Capella installation. Restart Capella. Then activate the corresponding viewpoint in Capella to enable it.

Was there any further step you took other than placing the files inside the correct folders, then restarting Capella?



Hmmm, the only specific thing I did was to create a new Capella model.
The viewpoint is automatically added to it .

After taking a look at it, you have to activate the viewpoint through “Viewpoint Selection”, by right-clicking the .aird
After the vp is activated, the menu should work



1 Like

Ahh… got it.

I was using the viewpoint manager (Windows > Show View > Other > Viewpoint Manager) to try and reference the viewpoint. It does not show up here.


Right clicking on the .aird file the option for viewpoint selection is available. From here the Cross Analysis can be selected.

On a new model, this will automatically be ticked. On an existing model this will need to be selected.

Thanks for your help with this @ErwannTraisnel :slight_smile:

For future reference:

To add to an existing model:

  • Right click on .aird file
  • Go to Viewpoint Selection
  • Tick “Cross Analysis”

If creating a new model, viewpoint will automatically be selected.

To create diagram:

  • Select element of choice
  • Right click
  • Cross Analysis > Init Cross Layers Diagram (CLD)

This will create a diagram under the element selected. This can also be viewed in the Representations Per Category, Cross Analysis Viewpoint.

Hope this helps :slight_smile:

Initial thoughts on the diagram it produces (just tried with functions so far):

  • On the element that is selected, it has to have a chain of Realised X Functions (where X is Logical/System/Operational).
  • If there is a break in the chain of Realised X functions the diagram will stop.

Where elements are broken down further within a layer such there there isnt a realised relationship (e.g. a function nested within a function), the relationship will stop. This does somewhat limit the useful ness of the add-on.

Hopefully, one of the developers can add further thoughts about this.

I appreciate all efforts made to develop the Capella Eco-system further.