Creation of EPBS Architecture and Undo of Obfuscate


I have 2 questions:

  1. I am not able to create EPBS architecture possibly due to cross mark at project name. Is there way to fix this?
  2. I tried ‘Obfuscate model’ option and now all the architecture names are encrypted. How to undo this step?

Answering the “obfuscate” question: you cannot undo an obfuscate, that’s the goal, to obfuscate your model so that you may share it with others without having them being able to guess what was there at the beginning.

Is there really a use case in which someone wants to obfuscate his model so that nobody, not even himself can look at the original any more, without needing to manually backup before?

The other case is what op experiences: The user doesn’t know that it makes no backup. (The action says “No Backup”, but it should really also say “No Undo”!. The user obfuscates and loses his data.

We really should balance between security and usability and here, the security fanatics went too far IMO.

Well, I certainly agree that one should generally backup his model before obfuscating them.

I do not agree that the user do not know that it makes no backup:
no backup

You will have the same drawback if it makes an automatic backup: the user may end up sending its Capella project with the obfuscated model… and the backup, therefore potentially sending sensitive information without knowing it…

So in my opinion I think it is safer that no automatic backup is made. But this is just my opinion. And I agree that maybe the message/warning in the popup may be even more explicit, like you were suggesting, “no undo, loos of data, etc…” and in red!

Stephane

Hi,

an idea:
the obfuscate command offers an option to generate automatically a copy xyz-model_obfuscate of the model and opens this in the model-explorer.

How about this?

Kind regards

sounds like a good idea to me!

Thank You Stephane, Haage, FDorner for your suggestions. Could you please help me with this as well:

  1. I am not able to create EPBS architecture possibly due to red cross mark at project name (Paper Media Scanner) as shown in the attachment. Is there way to fix this?
    https://forum.mbse-capella.org/uploads/default/original/1X/b481c7e97714115d83d49c940e9a0a79f4ec5bae.png

Then let the tool do it for him. It just offloads work to the user. Simple things should be simple.

Not sure what the red cross is, but you could just create a new project, and copy the epbs architecture element from the .capella xml file to your projects .capella file, and make sure thatthe two nested elements Physical Artifact Realization and Physical Architecture Realization target references are updated to point to your projects Physical Root Component and Physical Architecture respectively.

Hi,

The menu “Add Capella Element / EPBS Architecture” doesn’t work in your case?

Philippe

Once created, depending on how you model has been created, can you ensure that the “EPBS architecture” is enabled in “Viewpoint selection” dialog. Otherwise you will not be able to create diagram at this architecture level.

EPBS3

Philippe

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.