Convert Operational Actor to Operational Entity


I created, and subsequently used, an Operational Actor (OA). But it should really be an Operational Entity (OE).

Is there a way for me to convert the OA to an OE? In the screen capture below, I would like the dc965… to become an OE, just like c0956… to the right of it.


If this is documented somewhere, you can also point me in the right direction.



Yes: while you have your actor selected, in the properties windows, click on the “expert” tab. You’ll see the property “Actor” that you can set to False.


I do not see the Expert tab. This is what I see:

Property tabs

I see what you are referring to in Section 4.14 of the documentation.


Right sorry, I forgot to mention that you should select your entity from the project explorer view - ie when you’re on your diagram and have the actor selected, hit the F8 key.

Uhh, still no progress. (I am on Capella 6.1)

When I open the properties dialog from the project explorer, I get a properties window with 4 tabs, but no Expert one.

The screen capture shows the actor (712bad…) in the diagram, the associated entry in the project explorer (after pressing F8) and the property window that opens when I double-click on it:

(Thank you very much for your help so far)


That’s right you won’t see the expert tab when you double click, you should see it if you look at the property view at the bottom right of the screen.


Still no luck. See below for details.

The documentation (User Manual/User Interface/Properties) states the following:

  • Expert (named “Semantic” on diagram elements): all attributes and relation defined within Capella - disabled by default, please refer to [Capella Capabilities]

I wonder if my setup has this disabled. I looked in Window/Preference, but did not see where I can adjust the preferences.

Going back to what you suggested, when I click on the Actor in Project Explorer, the Property view at the bottom of the screen shows these four tabs:

Property View from Project Explorer

Oh that’s it then!
I was trying on Capella 6.0 but apparently they changed which capabilities are enabled by default in Capella 6.1
So you should check this Capability ni the preferences (Menu Window->Preferences) and you will see it!

All the best,

Whohoo! Works :slight_smile:


1 Like

One note:

(This is on V6.1)

In addition to unchecking Actor property, I also had to uncheck the “Human” property in the Expert list of properties.

Otherwise the Validation would warn me that this Entity cannot be Human.

1 Like