Cloning a Capella Project

Hello ,

I wanted to know if there was a way to clone a Capella Project or save an existing project using a different name.
I want to be able to have the same project under different names and be able to load both of them at the same time on my project explorer.

Thank You

Hello Marieme,

For a ‘simple’ Capella project without dependency on another model, it’s quite simple. You can just copy past the project in your workspace.
Would be a bit more tricky for a project with dependencies.

Hello Samuel,
Thank you for the quick reply.
The copy/paste worked indeed. However the two models still share the folder names. I wonder if that can be changed as well without losing the content

can you share a screen capture of what you mean?

Sure, this is what I mean. I copied M1 to create M2 but the .aird .afm etc. files share the same name.
image

Ah ok then you can right-click on the aird and rename it, maybe the same for the .melodymodeler file.

when i do that i lose the model structure (see difference between the two images).
Actually the melodymodeller won’t expand on the project explorer
image

image

What Capella version are you using?
Can you detail the steps that bring you to that state? Do you do the renaming on the .melodymodeller first?
Thanks
Stephane

I’m using Capella 1.4.2. I copied M1 to create M2. Afterwards, I renamed the .afm , .aird then the .melodymodeller in that order.

ok let me try this.
Stephane

Here is what I did:

  • created a M1 project
  • did a copy and then a paste of the M1 project in the project explorer by right clicking on it that lead to the creation of the M2 project
  • right clicked on rename of M1.melodymodeler to M2.melodymodeler on the M2 project
  • right clicked on rename M1.aird to M2.aird on the M2 project

I was then able to open and work fine on M2.
Can you try this?
Stephane

I still had the same display after replicating your steps . I had to manually add the .melody modeller file to the .aird to get the details to appear on the project explorer (see highlighted section on the image ).
Thank you for you help Stephane,

Marième

image

Please contact me on linkedin and we can make a zoom call maybe, this should be working.

The issue is resolved: I was using Capella Studio instead of Capella. I Tried the same steps on Capella on Stephan’s recommendation and it worked.

Thank you again.

1 Like
Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.