Capella version compatibility issue with imported plugin

Hello, I am using Capella studio 1.4.0 (Kitalpha 1.4.0) in order to export a plugin that I have developped for Capella.

My problem is that my created plugin works only on a few versions of Capella…
It works fine on Capella 1.4.0 and 1.4.1 but not on other versions.

Where does this problem come from and how to fix that compatibility issue ?

My plugin also work well for versions V5.0.0, V5.1.0 and 1.4.2 of Capella

But doesn’t work on versions V1.3.1, V1.3.2 and V1.3.3

Is there a way to make it functionnal on all versions of Capella ?

Once you tell us what is actually not working, someone might actually try and help you.

Hello
Same I develop my own plugin that is working on Capella Studio V5.0
Now I want to use it on V1.4.2 but not working on it.
is there any proper reason behind that or how I can use it with an older version than V5.0

So if you would tell us “what” is not working, maybe someone can help…

You may want to use the Capella Studio dedicated forum: Latest Capella Studio & Kitalpha topics - Eclipse Capella Forum (mbse-capella.org)

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.