Capella Library

Hi,
It appears to be a bug. Please create a ticket in Capella
Bugzilla.
Regards,
Christophe.

Hello,
I don’t have rights with my account to create a ticket.
regards,
frederic

Hi,
Thanks for the remark. Normally you should be able to.
Could you screenshot the error message?
So that I could transfer it to the involved team in charge of Bugzilla accounts management.
Regards,
Christophe.

Hi,
Frederic said
Quote:
In a OAB diagram , I can add my shared entities (from the library with a drag and drop), it’s perfect.
I created a Library with Operational Entities but when I try to drag & drop elements from the explorer to an OAB diagram in another model, nothing happens.
Is it a bug like Frederic issue on OES diagrams?
Or could someone explain how to use elements from a Library in different models?
Thanks,
Jérôme

Hi,
First, check that your project references well the library using contextual menu as shown in following picture:
If this is done, the library should appear in the project:
Then, from this library, you could use drag-n-drop on elements to diagrams (this is a workaround).
There is a bug indeed, elements should be draggable-n-droppable from the library project or using show/hide on diagrams but I just checked and this is not the case.
Could you fill a bug on Bugzilla so that to mention this fact?
Best regards,
Christophe.

Good morning,
I am Steven CELESTIN; I work for Airbus Defense and Space.
My questions are:

  • Is it possible to create a library of physical components which can be dragged and dropped on a project?
  • Is it the proper way (as detailed below) to create a physical component which contains functions.
    I have tried this:
    ■ File > New > capella library > “MyLibrary”
    In this library I created a physical component which contains two functions:
    Node PC “PC1”

Deploy Behaviour PC “PC2” > Physical Function “PhysicalFunction 1”
Deploy Behaviour PC “PC3” > Physical Function “PhysicalFunction 2”
Then, I created a REC and a RPL.
■ File > New > Capella project > “MyProject”
■ Libraries > Manage reference > “MyLibrary”
Then, I tried to drag and drop “PC1” from “MyLibrary”, which is included in “MyProject”, into a new Physical architecture diagram in “MyProject” but it did not work.

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.