Capella launch failing

Hello evryone
After downloading capella for trial, i extracted it and launched it. After getting asked for workspace I got the following message:
An error has occurred. See the log file
Log file:
!SESSION 2020-05-28 19:03:15.337 -----------------------------------------------
eclipse.buildId=unknown
java.version=11.0.7
java.vendor=AdoptOpenJDK
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Command-line arguments: -os win32 -ws win32 -arch x86_64
!ENTRY org.eclipse.egit.core 1 0 2020-05-28 19:04:36.977
!MESSAGE Using Apache MINA sshd as ssh client.
!ENTRY org.eclipse.osgi 4 0 2020-05-28 19:04:39.295
!MESSAGE An error occurred while automatically activating bundle org.polarsys.capella.core.sirius.analysis (639).
!STACK 0
org.osgi.framework.BundleException: Exception in org.polarsys.capella.core.sirius.analysis.activator.SiriusViewActivator.start() of bundle org.polarsys.capella.core.sirius.analysis.
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:863)
at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:791)
at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:1013)
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:365)
at org.eclipse.osgi.container.Module.doStart(Module.java:598)
at org.eclipse.osgi.container.Module.start(Module.java:462)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:493)
at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:117)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:570)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:330)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:396)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:474)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:423)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:415)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:155)
at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
at org.eclipse.osgi.internal.framework.EquinoxBundle.loadClass(
I am working on windows 10 (64 bits)
Capella 1.4.0
I tried modifying the ini file with
-showsplash
org.polarsys.capella.core.platform.sirius.ui.perspective
-vm
C:\Program Files (x86)\AdoptOpenJDK\jre-8.0.252.09-hotspot\bin\java.exe
But it didn’t change anything. Any idea where is th eproblem from?
Thank you for your help.
Regards
Jean-Gui

.log
.log

Hi Jean-Gui,
Yes, you have Java 11 installed on your machine and Capella is picking up (you can see it here: java.version=11.0.7)
You can try a few things:

  • uninstall Java 11
  • make sure that when you modify the eclipse.ici file, you place the -vm … argument before the -vmargs one
    I hope this helps

Hello Stéphane
Thank you for your answer. Uninstalling Java11 was the right call. About the -vm and -showsplash arguments it returned me an error code1 so I removed both, try with original .ini file and it was good. Problem solved.
Thank you
Jean-Gui

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.