Can't create any new diagrams


I created a new Project and successfully created a few Operational Analysis diagrams. I did have some problems where I couldn’t create an Interaction in one diagram, but just moved on.

Now I’m in System Analysis and I can’t create any new diagrams under here. I first tried the Contextual System Actors diagram and the mouse pointer changes to busy, then returns to an arrow after 5 seconds or so.

I’m using 5.2. I found this error elsewhere on the web and it suggested it could be where it was located, so I have tried moving Capella to c:\capella. But no change.
Also tried re-installing VC++ redistributable (another suggestion). Also tried installing the latest JRE.

Checked the logs and found this.

!SESSION 2022-03-21 09:58:59.005 -----------------------------------------------
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_AU
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.egit.ui 2 0 2022-03-21 09:59:24.847
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: ‘C:\Users\ChrisGibbons’. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

!ENTRY org.eclipse.ui 4 0 2022-03-21 09:59:33.311
!MESSAGE Unhandled event loop exception
at org.polarsys.capella.core.sirius.ui.actions.NewRepresentationAction.(
at org.polarsys.capella.core.explorer.activity.ui.hyperlinkadapter.AbstractCapellaNewDiagramHyperlinkAdapter.initNewRepresentationAction(
at org.polarsys.capella.core.explorer.activity.ui.hyperlinkadapter.AbstractCapellaNewDiagramHyperlinkAdapter.createDiagram(
at org.eclipse.amalgam.explorer.activity.ui.api.hyperlinkadapter.AbstractNewDiagramHyperlinkAdapter.linkPressed(
at org.polarsys.capella.core.explorer.activity.ui.hyperlinkadapter.AbstractCapellaNewDiagramHyperlinkAdapter.linkActivated(
at org.eclipse.ui.forms.widgets.AbstractHyperlink.handleActivate(
at org.eclipse.ui.forms.widgets.ImageHyperlink.handleActivate(
at org.eclipse.ui.forms.widgets.AbstractHyperlink.handleMouseUp(
at org.eclipse.ui.forms.widgets.AbstractHyperlink.lambda$3(
at org.eclipse.swt.widgets.EventTable.sendEvent(
at org.eclipse.swt.widgets.Display.sendEvent(
at org.eclipse.swt.widgets.Widget.sendEvent(
at org.eclipse.swt.widgets.Display.runDeferredEvents(
at org.eclipse.swt.widgets.Display.readAndDispatch(
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(
at org.eclipse.ui.internal.Workbench.lambda$3(
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
at java.base/java.lang.reflect.Method.invoke(
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(

The same error occurs for:

  • System Functions / Operational Activities Matrix
  • System Actions / Operational Entities Traceability Matrix
  • Functional Breakdown
  • Functional Dataflow Blank

Any suggestions please?

There is a “repair” function when you right click on your aird file or the project file, have you tried it?

Thanks for pointing that out. Tried that, no change.

Maybe deleting the diagram where you think you have the issue with the interaction?
Although I don’t see why this would be causing the issue you’re having…

It was a migrated project - from 5.1 to 5.2. So maybe the issue was with the migration. I haven’t checked logs for that.

I haven’t done that much. I’ll try re-creating the project, I expect that will resolve it.