Advanced Class Design addon issues

Hi all,
I am trying to use the Lab4Capella addon

I copied the plugins in the dropin/plugins folder but the addon seems not to be activated, nor specific errors can be found in the error log.

Any hint?

The problem with dropins is that you won’t get any error during installation even if there are. Try installing via the update site instead and see if you encounter any error during the installation.


Hi Stephane,
I tried to setup an update site for the plugin, Maybe I did something wrong, because it was my first time… Apparently the update archive is correct because it is recognized by Eclipse. The installation of the feature fails because of missing dependencies.

Please find attached the error log.

adc-install.log (1.2 KB)

I have not followed precisely what is going on with this add-on but from the wiki I see it requires Capella 1.4.2 - Home · labs4capella/advanced-class-diagram Wiki · GitHub
That may be your issue.

I tried to used it, because in the wiki it is also mentioned that it is not version dependant. I will try to find out if it can be made compatible with latest Capella releases.

I found out that the addon has org.eclipse.sirius.query.legacy among its dependencies, but none of the provided classes is referenced. I removed it from plugin.xml. With such a modification, I was able to install the addon and activate the viewpoint.

Unfortunately, when the Advanced Class Diagram Layer is enabled all properties disappear.