Add-ons Installation failures

I am new to Capella, and just installed v5.0. I had failures installing all components for the Requirements VP and Transition System to Subsystem addons. For the Req VP, I receive the following error:

Missing requirement: CapellaRequirements CDO Model 0.12.0.202101221536 (org.polarsys.capella.vp.requirements.model.cdo 0.12.0.202101221536) requires ‘osgi.bundle; org.polarsys.capella.core.data.gen.cdo 0.0.0’ but it could not be found

and for the S2SS I get:

Missing requirement: System2Subsystem Tests 1.5.0.202012071627 (org.polarsys.capella.transition.system2subsystem.tests.ju 1.5.0.202012071627) requires ‘osgi.bundle; org.polarsys.capella.test.validation.rules.ju 0.0.0’ but it could not be found

Did my Capella install go wrong? Am I missing a requirement for these addons? Any help would be appreciated.

Hi Brent,
I have not tried this on Capella 5.0 but:

  • on the Req VP, you should probably uncheck one of the features you are trying to install, The error you get is related to the fact that you are trying to install a feature related to the compatibility of this add-on with Team for Capella (https://www.obeosoft.com/en/team-for-capella) so you do not need to install it if you’re not using Team for Capella
  • Not sure about the other one but it looks like you are trying to install some tests. So maybe again there is a feature that you may uncheck as you do not need the test for this one. But honestly, I am not sure. Also make sure you are installing this version: Addon System to Subsystem Transition v1.5.0 has been released

Let me know if this helps, if not I will try to find some time to test this.

All the best,
Stephane LACRAMPE
Obeo Canada

Hi Brent,

Just to complete Stéphane’s answer, as in the following image, the only feature you need to install is “Capella Requirements Viewpoint” and leave the others unchecked (if you’re not using Team for Capella, XHTML generation or testing feature).

RequirementVPInstallation

Best regards,
Minh-Tu

Thanks to your quick responses, I have these installed.

Stephen,

Thanks for your quick reply. I got this working now.

Brent

image001.jpg

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.