Add-on Requirements Viewpoint v0.12.0 has been released

Hello,

Add-on Requirements Viewpoint v0.12.0 has been released for Capella 5.0.0.

Requirement’s ReqIf.Text field is now imported into Capella model as richtext description.

For more details please consult the Release Note.

Download links:

Best regards,
Philippe

2 Likes

Thank you very much guys, this is great!
Stephane LACRAMPE
Obeo Canada

ON EDIT: I was able to get the Requirements VP installed by downloading and unzipping. I used the file:/{folder} method. Still can’t seem to get update sites enabled and get past the URL issue. But at least I have a workaround.

Hi Philippe,

I am committing some sort of silly user error. When I put the site URL in the Available Software dialog, I get the following following Error Contacting Site response:

image

“No Software site found at
https://download.eclipse.org/capella/addons/requirements/updates/releases/0.12.0/ …”

Do you have a suggestion to help me get past this error? I am using Capella v5.0.0.

Thanks,
Bob

Hi, yes,

The url is incomplete and you shall use the downloadable zip url in the above link.

you can download the zip file and use it Help > Install new Sotfware > Add > Archive
https://download.eclipse.org/capella/addons/requirements/updates/releases/0.12.0/Requirements-updateSite-0.12.0.202101221536.zip

or refer it as url Help > Install new Sotfware > Add > Location
jar:https://download.eclipse.org/capella/addons/requirements/updates/releases/0.12.0/Requirements-updateSite-0.12.0.202101221536.zip!/

Regards
Philippe

Hi Philippe,

Thanks for the reply. I have been able to download and install. I learned that it is advisable to install the DocGen add on before the Capella Requirements Viewpoint add on as there is a dependency. I did make several attempts to install the CDO features until I learned that the CDO is only needed in Capella collaborative environments (e.g. Capella for Teams).

I have successfully exported a ReqIF from Doors Next. The ReqIF definition included only one module of product level requirements. That ReqIF imported successfully into Capella. I am making progress.

Thanks,
Bob

1 Like

Hi

Is this Add-on works with Capella 5.1.0?

Regards

Patrick

Yes but the one that works with Capella 5.1.0 is v 0.12.1 - you’ll find it here: https://github.com/eclipse/capella-requirements-vp/releases

Stephane LACRAMPE
Obeo Canada

1 Like
Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.