Add-on Requirement VP - Cannot add a Capella Type Folder


I am new to Capella and so to this community.
In an attempt to add requirements to my capella model, I have installed the add-on Requirements Viewpoint.
For some reason, Capella is not able to install 2 of the 4 items in the installation file. I cannot install Capella Requirements Tests Feature neither VP CDO Feature Developer Resources.
I suppose this could be the reason why I am not able to add a Capella Type Folder under any Architecture Block (as suggested in the manual).

Under the filter and customization, I have added the Requirement VP types. I thought this would be enough to see them and add.
Are the two missing items in the installation what is denying me the possibility to add a type folder? Do I even need them? Form what i read in this forum, not really.
Am I missing something else to add a Capella Type Folder?

I am using Capella version 5.2 and already tried installing both add-on Requirements Viewpoint v0.12.1 and v0.12.2.
I have installed XHTML Documentation Generation before the requirements VP add-on.
There is no ReqIF import to be done so i have not tried that.

Thanks in advance!

Hi Alexandre and Welcome!

I don’t think that the fact you cannot install these 2 features is causing the issue.
I think what you are missing here is to make the types visible in the project explorer. Indeed some information is hidden/filtered by default in the Capella project explorer.

To do that, select the “customize View” wizard in the Capella project explorer:

Tech - view

An then, make sure that these 3 items are NOT selected:

Tech - custo

I hope this helps.

All the best,
Obeo Canada

Hello Stephane,
Thanks for your quick reply.
I did as you suggested (unselecting!) but I still don’t get to see them.

Best regards,

Oh, that is what you actually said in your initial post - sorry I missed that.

So what you are missing is that you actually need to reference the Requirement Viewpoint to your Capella model (thus creating a dependency).

To do that, open the Viewpoint Manager view (Window->Show View->Other and then select the Viewpoint Manager in the Kitalpha section), and then select your arid file in the Capella project explorer, make sure your session is open, and in the Viewpoint Manager view, select the Capella requirements line, right-click and select Reference. From the your viewpoint will be activated and you’ll be able to create Requirements and Types.
(More info on this in the help: Help->Help Contents and then Requirements Viewpoint Guide >User’s Guide->Viewpoint Manager)

All the best,

Hello Stephane,
Thanks! That worked.
I completely missed that part of the manual… I see now.
Best regards,

No worries, I am glad that it worked, and feel free to reach out if you have other issues with creating your Req types!