Add-On Installation problem

Hi all,

I am currently trying to install Add-ons on Capella, but I’m having a few problems doing it.

For PVMT for example, I unzip the corresponding folder in the dropin folder, but when i launch capella, it seems that the add-on have not been loaded and activated. I have tried also to go through Help → Install new software but it has not worked as well.

Does someone have experienced something similar ? Am I doing something wrong, or am i missing an installation step ?


Hello there!
Have you found out what was the problem? I am at almost the same situation now, wondering is there some kind of pitfall or is there something wrong with my brain

Generally speaking, don’t use dropins for installing Capella addons. Use update sites.
Then check that the add-on you’re installing is compatible with the Capella version you have.

That’s understandable and actually makes sense…
Still, I deploy Capella to the server where users connect to via docker and drop-ins are the most convenient way to install add-on during deploy. So, had a hope that there is a way to make it easy.

Anyway, cheers for answer. Gonna make it a long way…

Yes and the main problem with dropins is that when you have a problem, there is no way to get information on what the problem is, so if you’re succeeding in using dropins, that’s great, but if you have a problem, we cannot really help…

1 Like

How can we bring this advise to new users? Where is this documented? Like @JustNickSPb, I’ve been using drop-ins not understanding the downside of them.

Bringing the issue here is a first step. Maybe raising an issue in the Capella github would help. On our side we’re going to bring the discussion with Thales so that it get changed in the installation pages.

1 Like


Could you provide some more details about your installation ?

Which Capella version ?
What other addons do you use ? (either installed through update site or by dropins)