System to Subsystem Transition not working (v1.6.0)

Hello,

I am on using Capella 5.2.0 and I have installed the v1.6.0 of the capella-sss-transition add-on using the dropin method.
I downloaded the correct dropin zip and copied the content in the already existing dropins directory in Capella installation folder.

The right-click option to do the “System to SubSystem Transition” is now available. I create a new project using the “SA Transition Options” window, the new project gets successfully created, but then when I click ok to proceed with the transition, the Diff/Merge dialog does not appear and simply nothing happens. The newly created project remains empty and no content is created from the original project.

I tried doing the transition by right-clicking the logical component both in a LAB diagram and in Project explorer, I tried Horizontal and Vertical SA transition, but nothing ever happens. Do you perhaps have an idea what might be the issue?

Thanks a lot.
Matej

Hi all,

I ended up downgrading the add-on to v1.5.3 and that works. There seems to be a compatibility issue between Capella 5.2.0 and capella-sss-transition v1.6.0

1 Like

Hi,

Indeed, version 1.6.0 is for Capella 6.0: Releases · eclipse/capella-sss-transition · GitHub

Regards,
Arnaud