Python4Capella Interpreter Help


I am attempting to install python4capella, and I am having an issue when trying to reference the interpreter. The instructions state the following:

Select the Window > Preferences menu

  • select the PyDev / Interpreters / Python Interpreter
  • select the Scripting / Python Scripting (using Py4J) (/!\ not Scripting PyDev)
  • select the Scripting / Script Locations
    • add /Python4Capella/sample_scripts by clicking the Add Workspace button

However, when I go to Windows>Preferences, I don’t see any of these option available (Pydev/Interpreters/Python Interpreter), so I am not sure if I needed to add anything else, but I have completed all of the steps up to this point. The only difference I had was that I never got the pop-up that stated the “Python interpreter is not currently configured.” Any help would be appreciated!

Did you process with the installation of the Python4Capella update site in your Capella (see installation section) ?
After performing the installation and restarting your Capella, you should be able to see those preferences.

I went to Help > Install New Software, which is where I added my unzipped file from the Update site, and finished installing it. I restarted and still do not see anything under preferences.

Update: I forgot to click on the “Uncategorized” folder, as soon as I installed it, I was able to access that preference.

Yes those preferences come from dependencies of Python4Capella like EASE and PyDev.