Problem in Creating new Activity Explorer page

Hello,
I’m working on Capella Studio ver1.2.1 (Capella 1.2.1, Java 1.8 ) to create a new page on Activity Explorer. I tried to do just a simple model with only one page, one section, one activity but it just didn’t work even when I’ve already activated the model (see Capella Studio ver 1.2.1 pic).
But when I tried to just copy my code into Capella Studio ver1.1.2 (Capella 1.1.1), my Activity Explorer worked like i’ve expected. (see Capella Studio ver1.1.2 pic).
So I think the problem is not in my code but maybe I missed some steps to turn on my model in ver 1.2.1. Could anyone give me any suggestions please?
Thanks in advance!

Hello Travan,
It seems a regression in Capella Studio 1.2.1. I create a bugzilla to investigate on this issue.
ticket 2157
Best regards

Hi again,
I also found that, when I right click on the project’s model file, I can only create my defined model’s element, but when I right click again on the my new model element, it does not show the “Add Diagram/Table” element. Is it related to the bug mentioned here?
https://forum.mbse-capella.org/t/611/
Thanks,
Parsa

Hi Abka,
Thank you for your help! I checked your link on Gerrit, but I still don’t know how to take advantage of those codes. Could you give me a compiled version of changed Cappella Studio or a guide documentation?
Thank you again!

Hi Parsa,
Have you fix your problem yet?

Hi Travan,
No, the issue is still there!
Regards,
Parsa

Hi everyone,
i’m starting a capella customization project, i wanted to ask you if you have a guide/tutorial for customizing the activity explorer with the viewpoint DSL dev method not the plugin methode ?, thanks.
Best regards,
Ahmed

Hello.
There is a pdf document on this page which explains the different extension points :
https://wiki.eclipse.org/ModelingAmalgam/ActivityExplorer
If it is in the context of a viewpoint, it is easier to use Capella Studio. In viewpoint DSL, there is an editor for the customization of the Activity Explorer.
If not, have a look / reuse the extensions, code produced by Viewpoint DSL.

Thank you for your response Sir !

following the pdf document im getting this error :
https://drive.google.com/open?id=1NdclLEaDK1k6HXji-4cKXFbKfa KE7_kG
https://drive.google.com/open?id=1vBvkkItKI7juIJPRynzj2SWmpz XGvMeJ
i used Capella studio 1.1.0 and 1.2, thanks

Hello,
The super class AbstractNewDiagramHyperlinkAdapter does not define constructor with 2 parameters. It defines only one parameter as EObject.
Calling super constructor as: super(ActivityExplorerManager.INSTANCE.getRootSemanticModel( )) will be sufficient!
You can access to activity explorer source code on amalgam git repository here:
https://git.eclipse.org/c/amalgam/org.eclipse.amalgam.git/tr ee/plugins/org.eclipse.amalgam.explorer.activity.ui
And for example of implementation of an activity which create diagrams have a look to the example provided in capella studio (example called Component sample):
https://git.polarsys.org/c/kitalpha/kitalpha.git/tree/archit ecture description/dsl/examples/plugins/org.polarsys.kitalpha.vp.co mponentsample.activity.explorer/src/org/polarsys/kitalpha/vp /componentsample/activity/explorer/activity/CreateNewDiagram Activity.java
Regards,
Faycal

Hello,
thank you for your help !
Best regards,

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.