'Paste as link' does not work in Capella 1.4.[12]

Hi everybody,
My name is Marcin Gramza and I am rather new user of Capella. Although I am at the start of the journey, I must say I like the methodology quite a lot.

I have an issue with writing the Documentation.

Inserting the links in the Documentation tab of the Model overview does more work. When I use the ‘Paste as Link’ (Ctrl-Shift-V) or an option in the editor’s menu (e.g. URL to a diagram) the diagram’s title is pasted but the hyperlink is not created.

Also when I open the Documentation of the example projects, all links are shown as plain text.

I am using free version of Capella. I have tried the versions 1.4.1 and 1.4.2 and in both had the same effect.

Has anybody seen such issue? If so, what is the solution?

Thanks,
Marcin

Hi Marcin,

This documentation tab (the rich-text widget) has sometimes tricky behavior depending on the configuration of users.
First of all, please read the release note of Capella 1.4.2 as there has been an improvement on this: https://github.com/eclipse/capella/wiki/Release-Notes-1.4.1#provide-facilities-to-create-hyperlinks-towards-model-elements-or-diagram-in-capella-richtext-description

Now I am not 100% sure what your problem is, but sometimes this is due to some installation issue. What OS do you use? What web browser? What java version?
Do you have any error in your .log file (under the .metadata folder in your workspace)

All the best,
Stephane LACRAMPE
ObeoSoft Canada

Hi Stephane,
Thank you for your response. I have tried different options (summarized below) but with no luck so far. I run Capella on MS Windows 10 64-bit, Enterprise Edition.

And indeed, I try to copy-paste links as described in the release notes document that you have provided.

Here is what I have tried:
The starting situation: JRE: 1.8-251 + Chrome

  1. Tried to switch to Firefox as a default browser - no luck
  2. Upgraded JRE to 1.8-271 - no luck
  3. Tried to switch between 3 browsers with the upgraded JRE: Chrome, Firefox, Edge - no luck.

The log file does not reveal anything special as a result of inserting the link.

Do you have any other suggestions? Is there maybe another way of creating textual documentation with links to the Capella diagrams?

Kind regards,
Marcin

No, I am not sure why you have this behavior, maybe somebody from the Capella core team has an idea?

Hi, I’m facing the same problem. Creating links for images, model elements and web pages with the link button in the description editor doesn’t work. Links are inserted as plain text only. However, if I’m typing an url in the description editor as ordinary text, it will be recognized as link and inserted correctly.

I’ve made a clean installation of Capella 1.4.2 (without any plugins). As Marcin I’ve tried different JRE (1.8).

Kind regards, Peter

The problem appears also with Capella 5.0 on my computer. But no problems with inserting links in descriptions with Capella 1.3.1.

The problem also manifest in the saved data:

Capella 1.3.1:
<ownedCapabilities xsi:type=“org.polarsys.capella.core.data.ctx:Capability”

            id="a46be267-389d-45e8-ae78-2b914808b7b0" name="Capability 1" description="&lt;p>Here should be a link ***&amp;nbsp;&lt;a href=&quot;hlink://a46be267-389d-45e8-ae78-2b914808b7b0&quot;>Capability 1&lt;/a> ***&lt;/p>&#xA;">

Capella 5.0:
<ownedCapabilities xsi:type=“org.polarsys.capella.core.data.ctx:Capability”

            id="5b61d2a6-b10c-4f4e-a7fd-102db4061524" name="Capability 1" description="&lt;p>Here should be a link ***&amp;nbsp;Capability 1 ***&lt;/p>&#xA;">

I found a solution proposed on the eclipse community forum, that solved my problem: https://www.eclipse.org/forums/index.php?t=msg&th=1104408&goto=1829558&#msg_1829558

I had to unlock the template.html file of the nebula rich text widget.

2 Likes

Well, this is great to hear!
Stephane LACRAMPE
Obeo Canada

Hi Peter,
This is indeed the solution that works for me as well. Thank you very much for your post!

Marcin

1 Like
Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.