Modelling Accelerator: Interfaces From allocated Functions

Hello,
I tried using the modelling accelerator “Interfaces From allocated Functions”, with no sucess so far.
I have 2 components (let’s say A and B) linked by a component exchange, in which several functional exchange were added.
I tried to select only those 2 components before running the modelling accelerator, but it didn’t work neither.
The tool eventually mention some warning (Some logical function not yet assigned to a logical component), but those functions are not related to the components A and B in my system.
Is there anything in particular I need to check before running this accelerator in Capella 1.4 ?
Thanks in advance,
Mathias

Can you post a small example model so I can try to explain what happens?

Hello,
Here is a small example:
New project
New LAB diagram
2 New components linked by a component exchange
2 New functions linked by a functional exchanged, and allocated on the component Exchange
-> Modelling accelerator -> Interface from Allocated function
I was thinking that something will show up in the “Interface” package or something alike. I eventually tried to play with the filters as well but It is not displayed in the semantic browser anyway. The expert properties tabs indicate also that “Allocated Interfaces” is empty.
Thus I suppose that something is missing in my model to perform this accelerator but I don’t know what.

interface.PNG
interface.PNG

IIRC you have to allocate at least one ExchangeItem to the Functional Exchange.

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.