M2Doc detected bugs and errors

Hello,
I have been playing around with M2Doc lately, creating my own templates and such. For the most part I have been able to create what I want, but along the way I have stumbled upon what I perceive as bugs or errors. Are any of these known bugs or errors? Is there a list anywhere where I can consult the current known list of bugs?
The errors I have detected:
The New Template Wizard does not seem to work? I start it and follow it until the end, but when I click “Finish”, the window closes and absolutely nothing else happens. No word document is created; I have refreshed and even looked directly at the files in the workspace, but it is not there.
I use userdoc fields in the template, and have a table inside it. The first generation of the document is fine, but the second generation generates an error inside the generated document; at the start of the userdoc field, “userdoc copy error : null” appears in bold red letters, whether or not the field has been modified. The field works correctly otherwise (the text is still there, if it has been modified the modifications are present as well).
I have used “representationByDescriptionName” to great effect for most of my diagrams, but I have not gotten it to work for matrices, nor exchange scenarios. I use the text in the description field (selecting a diagram in the model browser, in the properties view selecting the Expert tab, Description is an attribute under the Misc header). This works perfectly for the other diagrams I have tested (LAB, LDFB, LFBD, LCBD…) But I tried it for “Logical Components/Actors - Logical Functions” and it did not work. Same with “Exchange Scenario”. Is it not the correct description? Where can I in that case find the correct one? Or is it a bug?
If anyone can tell me if any of these three topics are actually bugs, or if I am doing something wrong, that would be greatly appreciated.

Hello,
You can find the list for open bugs
here.

  • I’ll have a look at the wizard.
  • some problem are known with table in template construct and user doc. If you think you case is a new bug, you can open a new issue.
  • Did you use the asTable() instead of the asImage() service on the DRepresentation also you need to check if the nsURI for the table metamodel of Sirius is present in your template using the
    template properties wizard ?

Thank you for your reply.
I have looked into the bugs reported, and I did not see the one I described, so I added it.
Concerning the matrix, I found my reply in a different topic. I did not have the right descriptor, but now I have installed Sirius and learned how to get them. Though as you can imagine, I have not been able to get the image with asImage, since as you have so kindly informed me, it is a table. I tried replacing asImage by asTable, but it does not work, the asTable service is not found. However I do have the SiriusSession declared, asImage works just fine for the other diagrams.
I have installed all the nsURI proposed by the Template Properties Wizard exept for
http://www.eclipse.org/sirius/tree/1.1.0 (as this one will create a validation error if left in place).
http://www.eclipse.org/sirius/table/1.1.0 is present.
In the .validation file generated, I have the error “Couldn’t find the ‘asTable(org.eclipse.sirius.viewpoint.DRepresentation)’ service”.
I have also tried
m:im.asTableByRepresentationDescriptionName(‘Logical Components - Logical Functions’)
this does not give me any validation errors, but also does not give me the image of the matrix as I was hoping.
Can you tell if there is anything else I’m missing, or doing wrong?
Thank you for your help,
Ida

Your configuration looks fine, the representation description name is also correct.
Are you calling the asTableByRepresentationDescriptionName() service on the right object ? It should be a PhysicalArchitecture.
Are you calling the service on a PhysicalArchitecture ?

Thank you,
by calling asTableByRepresentationDescriptionName(‘Logical Components - Logical Functions’) on the logical architecture, I am able to obtain the matrix.
However, I do not understand why calling asTable on the representation does not work.
Do you see any error in the following code (la is a logical architecture)?
{ m:for im | la.representationByDescriptionName(‘Logical Components - Logical Functions’)->sortedBy(im | im.name) }
{ m:im.asTable() }
{ m:endfor }
Thank you again for your insights, it is very helpful.
Ida

Copyright © Eclipse Capella, the Eclipse Capella logo, Eclipse and the Eclipse logo are Trademarks of The Eclipse Foundation.